Hello Guest it is October 23, 2019, 01:55:52 AM

Author Topic: mach3 turn lathe spindle speed issue RMP Jumpy  (Read 213 times)

0 Members and 1 Guest are viewing this topic.

mach3 turn lathe spindle speed issue RMP Jumpy
« on: December 21, 2018, 11:44:05 AM »
HI to everyone here,

I am new to forum and to Mach3, I need help in Spindle speed. RMP jumping up n down.
I have a Boxford 160tcl, I have gutted the old electronics and fitted with
New 24v power supply and drivers main motion controller.

ECO-WORTHY CNC MACH3 USB 3 Axis 400KHz Breakout Board Interface Motion Controller Card CNC Interface Breakout Driver Board
3 x TB6600 Stepper Motor Driver Controller 4.0A 40V DC for CNC Milling Machine TE772

1 x Hall Element Module Magnetic




Also
TCST2103 Optical Endstop Light Control Limit Optical Switch 3D Printer CHIP 165

Universal spindle motor speed controller.
Wired up all the parts together and the machine works sweet, ie xz and turret all work as they should ran few g codes and the part came out nearly perfect, still need to fine tune the steppers.
Home switchs installed and work.

As I tried making threads its all went down. Been working on to get a stable RMP.
For index I used the Boxford encoder disc and made a 6mm slot for the TCST2103 and a rare-earth magnet for hall effect sensor.
The issue is same when using either one of the above sensor. The discrepancy is approx. 100 RMP above or below the actual RMP.

I have tried several method in the index de-bounce or pulley ratio, can’t seem to figure this out.
I have read serval forum past few months, been working on and off on this project. I have used Boxford original wire as its shielded.
Please help! Any guide will be much appreciated.