Hello Guest it is October 16, 2021, 06:34:40 PM

Author Topic: lua error  (Read 2127 times)

0 Members and 1 Guest are viewing this topic.

Offline madi

*
  •  17 17
    • View Profile
Re: lua error
« Reply #10 on: October 04, 2018, 03:01:24 AM »
dear bryannab,, have a look at my dro..
https://youtu.be/yybwEABNHzs

thankd

Offline madi

*
  •  17 17
    • View Profile
Re: lua error
« Reply #11 on: October 04, 2018, 06:52:10 AM »
i have reinstal the previous version of mach 4,, it seem ok,, the dro is stabale, message not appear,, but the problem is,, i forgot how to setup the revolution per mm ???, is there any way to copy a wizard and put in this version? :(
Re: lua error
« Reply #12 on: October 04, 2018, 08:21:43 AM »
Hello Madi,

You can use the StepsPerUnitCalculator wizard to calibrate your axes. Check out our support video on how to use it here: https://youtu.be/d-xCWDR0Uvg

All the best,
Bryanna
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial

Offline madi

*
  •  17 17
    • View Profile
Re: lua error
« Reply #13 on: October 04, 2018, 08:55:39 AM »
thanks bryannab,, the problem is this version dont have those wizard,, is there any way to copy that wizard and put on to this version,, i reinstal the version of 4.2.0.3233, thanks

Offline Stuart

*
  •  286 286
    • View Profile
Re: lua error
« Reply #14 on: October 04, 2018, 10:41:37 AM »
Did you save the profile file from the help drop down ( package up profile)

If you did just reinstall that it should work fine

This is of course this presumes you followed the manual and copied the stock one and gave it a new name eg your name the same with the screen set

Now I am old school don’t trust these new tangled computer me bobs , I have a spread sheet that prints out the settings in Mach but with blank entries the out with the biro and copy my working setting to that,then if you have a pc crash it’s a simple job to copy it back in

The manual also has the equation to work out your steps

Re: lua error
« Reply #15 on: October 04, 2018, 10:49:35 AM »
Hello Madi,

I tried to reply to this earlier and did not succeed. I included the wizard as an attachment, which you just need to download and move to your Wizards subfolder within your Mach4 directory in your C: Drive. You might also want to consider upgrading to a newer version, as many new features have become available since 3233 was released. There's a video on our YouTube channel that covers the safest way to upgrade to a new version, so that might be worth checking out if you're interested in moving to 2.0.3804. That is entirely up to you; I won't push you into it. :)

-Bryanna
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial

Offline madi

*
  •  17 17
    • View Profile
Re: lua error
« Reply #16 on: October 04, 2018, 11:02:31 AM »
Hi bryannab,
Unfortunately I don’t make any copies for the previous one,, if could how can I recover it?
I think it’s maybe something about the plugin,, I’m using wxhc cnc card,, they just have an update driver for version 1 mach 4,, that wah i was thinking,,
I will study the methods that u suggested,
Thanks

Offline madi

*
  •  17 17
    • View Profile
Re: lua error
« Reply #17 on: October 04, 2018, 11:11:27 AM »
allready update to new version before,, i got the mess when i downloded plugin for my cnc card..

Offline Stuart

*
  •  286 286
    • View Profile
Re: lua error
« Reply #18 on: October 04, 2018, 11:48:27 AM »
Hang on are you sure that a mach4 fully compatible card

All I can find is refs to mach3

I am sure there are threads on here about it being a problem card

But I may be wrong about this
Re: lua error
« Reply #19 on: October 04, 2018, 12:24:30 PM »
XHC makes a motion control card for Mach4, but it is not supported. Their motion controllers for both Mach3 and Mach4 have their problems (search the forum for customer comments on that topic) but I don't know that sticking to one version or another would help. If the one you're using now is working for you, then you definitely don't have to upgrade to a new build. But I would strongly consider saving up and investing in a more reliable, supported motion controller. Believe me, you won't want to miss out on some of the new features we're working on for the next build. ;)

In the meantime, you should now be able to use the wizard with build 3233.

-Bryanna
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial