Hello Guest it is May 20, 2024, 09:20:35 AM

Author Topic: THC Setup  (Read 1465 times)

0 Members and 1 Guest are viewing this topic.

THC Setup
« on: September 29, 2018, 12:45:16 AM »
I have a Proma THC hooked up. All the wiring appears to be correct. It will move the Z axis up and down in test mode. I have control of the Z when not in test mode. The THC doesn't respond when actually running a program, even when THC is enabled on the main screen

My problem: The Z DRO is not registering the movement and the THC ON, THC UP and THC DOWN indicator lights are stuck in the on position in the Diagnostics tab. From what videos I've seen and what I understand, even when the Proma is in "test" mode, the Z DRO numbers should be going up and down with the movement of the Z and the THC UP and THC DOWN lights should be going off and on in relation to the UP/DOWN of the Proma. I've tried switching to ACTIVE LOW and the situation is the same, except the indicator lights are off. I've tried every combination of pin numbers in the "Input Signals" tab and the result is the same. "Enable" is on for all three.

- I have my PROBE switch for the Z hooked up and assigned to Pin 10 and it's working just fine. I currently don't have any other switches (limit, home, etc) hooked up
- I hooked up a wire to Input 2 (and ground) on my BoB and set it for Z home (assigned Pin 15). M3 HOME light came on (stays on, just like the THCs), but if I touch the wires together one of the green indicator lights under "Port 1 Pins current State" will go on and off

If I were getting false input signals from my electronics (the BoB, Proma, etc), seems to me it would be logical that the indicator lights on the diagnostics screen would go out when I unhook the parallel port cable and USB cable from the computer. They're staying on regardless

Am I missing a setting or settings in Mach3 to set this up properly? Is it possible the parallel port on the computer is sending false input signals to Mach3? And, if this is the case, is there a way to reconfigure the parallel port?

Everything else is working properly on my table, I just can't seem to get the THC to work. I really looked everywhere I can think of for a solution to this. Either I'm not searching right or nobody else has had this problem (or at least they're not posting/talking about it). I'm really stumped here

My copy of Mach3 is a licenced copy and I'm running WinXP 32-bit

I've attached a copy of my .XML if you guys want to look it over. Any other info you need, I'll do my best to provide it as clearly as I can

Thanks for any advice you can give
Re: THC Setup
« Reply #1 on: September 29, 2018, 02:27:59 AM »
Update: I did the Automated Setup of Inputs in Mach3. I did it for "Z ++" (instead of Z Home). It assigned it to Pin 12 and set it as "Active Low". I touched my 2 wires together (simulating a limit switch trip) and the yellow "M3 ++ Limit" light went off and on like it should. Unplugged the parallel port while it was on and it went off, like it should

So, trying to figure out what is causing THC ON, THC UP and THC DOWN indicator lights to stay on/active. Again, if I were getting false inputs from the electronics, I would think the indicator lights would go off (just like the M3 ++ Limit did) when I remove the PP cable and they don't
Re: THC Setup
« Reply #2 on: September 30, 2018, 09:06:21 AM »
Any ideas at all?

Like I said, I'm stumped.