Hello Guest it is December 01, 2021, 10:06:02 PM

Author Topic: Mach 4 Probing issue - "Can't transition from MDI running to stop."  (Read 3571 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach 4 Probing issue - "Can't transition from MDI running to stop."
« Reply #10 on: September 10, 2018, 11:37:48 PM »
JimDingus,
Thanks, I'll try it out.
Re: Mach 4 Probing issue - "Can't transition from MDI running to stop."
« Reply #11 on: September 10, 2018, 11:40:33 PM »
Can someone direct me to the 3805 version? The website's latest download is still 3804.

Offline Tweakie.CNC

*
  • *
  •  8,864 8,864
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 4 Probing issue - "Can't transition from MDI running to stop."
« Reply #12 on: September 11, 2018, 01:43:05 AM »
Can someone direct me to the 3805 version? The website's latest download is still 3804.

ftp://ftp.machsupport.com/Mach4/DevlopmentVersions/
KEEP SAFE !
Re: Mach 4 Probing issue - "Can't transition from MDI running to stop."
« Reply #13 on: September 11, 2018, 09:15:50 AM »
Thanks
Re: Mach 4 Probing issue - "Can't transition from MDI running to stop."
« Reply #14 on: September 23, 2018, 11:02:57 AM »
Been away from my machine for a while. I've updated to the 3805 build, as well as the latest dev build, and now I'm getting an "Error(7) Motion Underrun." I have tried to reinstall profiles, adjust millisleep setting, manually perform G31 through the MDI, changed computers and adjusted buffer settings in the PMDX-424 performance config tab, all to no avail.
Currently I get the error consistently on the 3rd-4th probe. I am also using the modified M40 and M41 scripts for parameter logging.
This is getting very frustrating and I seem to have hit a dead end.
Has anyone had success in creating a probe level map file? I have also tried the auto generated probe file from "G-code ripper", "Autoleveller AE" and "Autoleveller AL." I have even manually typed the G31 commands in, through the MDI.
I am currently at a loss. Any help would be appreciated.
Re: Mach 4 Probing issue - "Can't transition from MDI running to stop."
« Reply #15 on: September 23, 2018, 11:47:23 AM »
Hi,
I use Autoleveller AE. I had a problem initially that sometimes there would be recorded more data points in the probe log file than
there were G31 calls. I tried all sorts of ways to find out why without success. In the end I wrote a Lua script that could deduce the correct
number of probe points and correct, if necessary, the probe log file.

The full discussion of it is on the Autoleveller forum.

May I suggest that you double check that Mach has not inadvertently put more data points in the file than you expected.

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach 4 Probing issue - "Can't transition from MDI running to stop."
« Reply #16 on: September 23, 2018, 05:27:03 PM »
JoeAverage,
I've eliminated the M40 and M41 calls, from the G-Code, until I can get it probing more than 3-points without getting the Underrun Error. So at this current point, I'm just probing and not writing to any file. As I'm typing this, I'm wondering if that is part of the problem. Last week when I was working on it, the M40/M41 calls were still in the code and I was getting the error at random probe points. Sometimes it would successfully probe 5-10 points and then hang up. However, now it consistently errors out at point #1 or #3. Not sure why it's chosen those two spots but I haven't successfully probed more than three points in the last 30+ attempts.
I'll put them back in and see if anything changes.
Thanks