Hello Guest it is December 02, 2021, 01:37:41 PM

Author Topic: Mach4demo & csmio-ip-s HELP  (Read 1087 times)

0 Members and 1 Guest are viewing this topic.

Offline WMT

*
  •  22 22
    • View Profile
    • www.intaglio.co.nz
Mach4demo & csmio-ip-s HELP
« on: September 06, 2018, 01:34:02 AM »
Hi.
Im toying with the idea of moving to mach4 from mach3.

Ive installed the demo version and plugin for CS labs csmio-ip-s motion controller.
When i run the demo. I cant select the csmio motion controller. It dosent show up in he options
Menu. Ive checked the plugin folder and the files are there.

Does it need to be a full version of mach4hobby to be able to test a motion controller?

Any help much appreciated.
Thanks

Offline WMT

*
  •  22 22
    • View Profile
    • www.intaglio.co.nz
Re: Mach4demo & csmio-ip-s HELP
« Reply #1 on: September 06, 2018, 01:46:06 AM »
Heres what pops up on the screen
Re: Mach4demo & csmio-ip-s HELP
« Reply #2 on: September 06, 2018, 02:49:12 AM »
Hi,
Mach4Hobby Demo will work fine.

Note that the CSMIO Mach4 plugin is a work in progress....it has a few quirks and CSLabs have proven to be slow to respond
with fixes/updates.

First you need to put both the plugin AND the signature file in Mach4Hobby/Plugins.

Then you need to enable the plugin in Mach......Configure/Control/Plugins.

Thereafter you can select the plugin as active motion controller. Note you will have to restart Mach AFTER enabling the plugins AND after
selecting the CSMIO plugin as active motion control plugin. Once you have selected an active motion controller other than Sim(ulator) then Mach will
run normally for six minutes before stopping until its licensed.

Craig
My wife left with my best friend...
     and I miss him!

Offline WMT

*
  •  22 22
    • View Profile
    • www.intaglio.co.nz
Re: Mach4demo & csmio-ip-s HELP
« Reply #3 on: September 06, 2018, 05:17:58 AM »
Thanks for your help Craig.

I have done all those steps you have showed me. But it wont allow me to select a plugin file in the add plugin folder. Mach4 wants *.m4plugw files.
And my file extensions are *.m4pw. I even tried renaming the extension. And mach4 really hated that!
Re: Mach4demo & csmio-ip-s HELP
« Reply #4 on: September 06, 2018, 08:20:13 AM »
Hello,

A few things to check: make sure you are not running third party antivirus software (Bitdefender, Malwarebytes, Norton, etc.) as they can sometimes prevent Mach4 from accessing necessary file. Likewise, you need to run Mach4 as an administrator. To do that, right-click on the shortcut and go to Properties, then Advanced, then select 'Run As Administrator' (if you're using XP the steps are a bit different, but that's the general idea). Next, make sure Mach4 is run from your C: Drive and is called Mach4Hobby. If it's somewhere else or the name of the directory was changed, that can cause issues like what you're seeing. One last thing to check is that your motion controller is connected. I am not very familiar with the one you're using (have not used it personally and only tested it a handful of times) but some motion controllers need to install firmware updates once connected in order to use them. One example of that is the UC100. I hope one of these helps!

-Bryanna
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial

Offline WMT

*
  •  22 22
    • View Profile
    • www.intaglio.co.nz
Re: Mach4demo & csmio-ip-s HELP
« Reply #5 on: September 06, 2018, 07:05:08 PM »
Thanks for both of your help.
Problem solved.
Microsoft Visual C ++ redistributable package: vc_redist.x86.exe had not installed properly. There was an error regarding microsoft MSU file.
Which required me to download a windows update.  Then reinstall visual C.