Hello Guest it is July 11, 2020, 05:55:58 PM

Author Topic: Ref All Home  (Read 492 times)

0 Members and 1 Guest are viewing this topic.

Ref All Home
« on: September 04, 2018, 11:36:49 AM »
 OK, UNCLE!

 Mach3   has decided to drive me of  my every loving mind!

I have a home built router with home switches and z probe plate installed. For years every thing worked just wonderful! On ref all home the y axis would cross the bed, touch the switch, back off and set zero. Then the x axis with slaved a would go to minus, touch off, square up the a axis last thing and set zero!   Great!

Then one day the Genie began to lose his miind! The y axis would start to move, but only an inch or so and stop and proceed to x axis. Then would not stop without repeated activation of both a and x home switches. Sometimes depressing the x switch while diagnostic screen is up will result in the led for x,y and a all lighting up.

Now and then the button script would disappear from the hard drive.

Tried different installations and different computers and the problem persists.

Most of my hair is now gone but not saving barber bills!
t

HELP!

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: Ref All Home
« Reply #1 on: September 04, 2018, 11:42:25 AM »
On more than one occasion, I've had a corrupt .xml file cause similar homing issues.
Simply replacing the xml file with a good backup fixed things right away.

If you are using the same (bad) .xml for multiple installations, the problems will follow the .xml file.
Try using a known good backup.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Ref All Home
« Reply #2 on: September 04, 2018, 12:47:28 PM »
Thanks for the responnse, Ger!

I've battered myself against it so hard and long that I'm confused about what I have done.

Will try fresh xml and see!
Re: Ref All Home
« Reply #3 on: September 05, 2018, 04:36:28 PM »
Fresh xml and fresh install of Mach. Problems disappeared to be replaced with new ones.

irratic behavior on ref all home""........
Will referance once only each time Mach is loades.
Y refuses to travel all the way to the switch and instead rers after an inch or so of travel.

Maybea diferent version of mach will handle diff?

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: Ref All Home
« Reply #4 on: September 05, 2018, 07:32:04 PM »
Sounds like noise issues...
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html