Hello Guest it is October 20, 2021, 07:17:43 PM

Author Topic: Mach4 Stops mid cycle, "Never happened before"  (Read 1938 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach4 Stops mid cycle, "Never happened before"
« Reply #10 on: September 07, 2018, 02:13:52 PM »
A video showing the problem, it happens when I say ”där” pay close attention to the line indicator window: https://youtu.be/-QLr-zM0RMc
The program is far from done.

Offline Mauri

*
  •  327 327
    • View Profile
Re: Mach4 Stops mid cycle, "Never happened before"
« Reply #11 on: September 07, 2018, 07:24:01 PM »
Zuxztah,
Mach4 V3481 and V3804 do not have any issues, they can process up to 2 Million lines of G-Code without issue.
Mach4 V3481 and V3804 also do not have any issues with Memory or CPU usage.
I can run Mach4 with many other programs at the same time with the CPU running at 100% all the time without any issues.
I have used it on runs that last  over 14hours straight on the CNC Mill with no issues.
Also have run jobs that ran each day for 14days straight with a max of about 14 hours a day.
Mach4 can run on an XP PC with 2GB ram and no Video card with over 1 million lines and not stop.
I use a PC with 8GB Ram and Win10.
So if it is not a licensing issue it must be something else.
Regards,
Mauri.
Re: Mach4 Stops mid cycle, "Never happened before"
« Reply #12 on: September 08, 2018, 02:35:07 AM »
You are probably right about that. It should not have any problems, and licensing isn’t a problem either at the moment, there have been issues with the licensing for me earlier. the PCID was constantly changing on my old PC, the new one have survived restart after restart, and that I also was able to run 20k+ lines 20min+ proves that the license is working,
One problem that I’ve never thought of is that I’m currently running version 3233, I’ll try to update to the newest version: 3804 and see what happens
 

Re: Mach4 Stops mid cycle, "Never happened before" Solved.
« Reply #13 on: September 08, 2018, 05:35:49 AM »
Updated Mach4 Hobby to 4.2.0.3804.
Fixed the Go To Work Zero problem by removing axis A0 from startup script.
Loaded the new Gcode file and ran it. Everything works like it should now, I don’t really know what the problem was but it fixed itself

Offline Stuart

*
  •  286 286
    • View Profile
Re: Mach4 Stops mid cycle, "Never happened before"
« Reply #14 on: September 08, 2018, 06:40:31 AM »
Bet you had a corrupt install and the update fixed it up

Glad you have it sorted

It’s a bit difficult to phrase any licence questions without inferring that you have not got it licence

Re: Mach4 Stops mid cycle, "Never happened before"
« Reply #15 on: September 08, 2018, 07:00:22 AM »
As you say that it may be a installation problem, I copied the old mach 4 Hobby folder from my old SSD to the new one and something must have gone wrong, a clean install and only copy over profiles macros and plugins seems to do the job. Super glad that it’s up and running again:)

 now I have other problems to solve, and that is to add a mpg wheel and 3stage rotary axis selector switch and maybe a switch to set 0,1 0,01 0,001 jogging..  found a guide with code online: Shane engineer “how to add a generic mpg pendant to Mach 4”

The problem with that code is that it disables “ ref all home” and all jog features on screen.. not how I want it to be. I want to be able to use both