Hello Guest it is December 11, 2019, 11:04:22 PM

Author Topic: Mach 3 seems to be adding circles to my code  (Read 516 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 seems to be adding circles to my code
« on: August 12, 2018, 07:48:58 AM »
I'm just getting started with this. I'm using CamBam Text button to create a letter.
I can make a profile cut or pocket and save the Gcode.
If I run the Gcode thru an online simulator it works as it should but when I bring it into Mach3, the letter is correct but there has been many circles added from it. The circles are of various sizes and are grouped together to almost look like spirals. They are what seems to be randomly added lines in the gcode. If i step thru the code in Mach it shows the circles turning white and if I run the code it does run thru them, but I can not figure out where they are coming from and why they only show in mach

Offline Tweakie.CNC

*
  • *
  •  8,021 8,021
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 3 seems to be adding circles to my code
« Reply #1 on: August 12, 2018, 08:07:31 AM »
Hi,

Go into Config. / General Config. and change the IJ mode then regen. the toolpath.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Mach 3 seems to be adding circles to my code
« Reply #2 on: August 12, 2018, 10:18:59 AM »
That worked. thanks

Offline Tweakie.CNC

*
  • *
  •  8,021 8,021
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 3 seems to be adding circles to my code
« Reply #3 on: August 12, 2018, 10:34:43 AM »
I am pleased that it works.

It all relates to how arcs are drawn within the CAD/CAM software and the resulting Gcode should ideally contain the G90.1 or G91.1 (as appropriate). The Mach3 manual explains more about Absolute / Incremental IJ Modes.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.