Hello Guest it is November 20, 2019, 10:51:48 AM

Author Topic: Improved g83 macro with bug fixes (I hope)  (Read 480 times)

0 Members and 1 Guest are viewing this topic.

Improved g83 macro with bug fixes (I hope)
« on: August 05, 2018, 12:02:02 PM »
The really slow speed of the G83 instruction in Mach3 Lathe bugged me so much I had to try to fix it.
See attached for my new version - you will have to rename it to M1083.m1s of course. I would welcome test results.
(It works fine for me, but I recommend some air cutting first.) There was a line of code missing in the version in the .062 kit, to do the rapid feed down to near the last drill depth. Without this instruction the Z axis crawled along at G1 speed the whole way, each time. I have fixed this. I have also tidied up the code a bit. There is still one wierdo in there which I do not understand, but it does nothing.
Now, this is for the lathe, so it ASSUMES that X=0 and ignores any X value you might provide. I suggest you move to X=0 BEFORE you use this macro. If you really want, a move to X=0 could be inserted in the macro, but I strongly prefer that such moves be explicit, so I know when they are going to happen.

Offline Tweakie.CNC

*
  • *
  •  8,006 8,006
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Improved g83 macro with bug fixes (I hope)
« Reply #1 on: August 06, 2018, 01:23:46 AM »
Looks like the macro did not attach.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.