Hello Guest it is May 20, 2019, 07:05:50 AM

Author Topic: Mach turn. Very very, very slow.  (Read 451 times)

0 Members and 1 Guest are viewing this topic.

Mach turn. Very very, very slow.
« on: July 27, 2018, 07:38:03 PM »
I have uncovered my lathe to do a quick job that is into day three now. Love it. But, I am up to trial number 9 now so am reaching out.

Requiring to machine a button I have downloaded a version of ECam. Its done all the correct things except for make my lathe work. Setting the piece in the chuck, hit go, the machine will jog at full speed (turned down because the saddle is not easy to move on this machine).

Then when cutting operation begins, the machine will feed at say 0.3 m/min. Real slow. Ive changed all the speeds in Ecam but no change. I am wondering whats going on?

I did think to try the rev/min option. No change. The spindle does have a speed sensor which is working but on or off, no change. Cant work out why the feed wont speed up. Can someone please take a look and see what is wrong with either my version of mach 3 or the gcode I have created with ecam?

Rgds Boyd
Re: Mach turn. Very very, very slow.
« Reply #1 on: July 28, 2018, 12:01:19 AM »
Hi,
when you first turn Mach on and Enable it the Feedrate is deliberately set to a slow speed.
Manually increase the speed override to the desired speed OR add to the 'Initialisation String' on
Config/General page. In the example I posted I set the feederate to 300mm/min, that is 'F300'.

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach turn. Very very, very slow.
« Reply #2 on: July 28, 2018, 12:41:17 AM »
Hi,
this is from your Gcode:

G1F0.5.....so your cutting speed is going to be 0.5 units (presumably inches) per minute. That seems pretty slow...
is it want you wanted?

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach turn. Very very, very slow.
« Reply #3 on: July 28, 2018, 01:00:39 AM »
Thanks guys. I decided to look at the gcode. And for sone reason its inserted 0.5 units beside every second line. Not what I requested from Ecam. But I edited it inside Mach 3 and pop. There we go. Not sure why Ecam did that am wondering if that will change when I buy the edition? Maybe?
Re: Mach turn. Very very, very slow.
« Reply #4 on: July 30, 2018, 04:35:06 PM »
Thats some good info on the initialization string. I will change that. One problem I encounter with Mach 3 is if I hit stop, it defaults to a feed of approx F50, and just wont speed up requiring a restart. Also the feed override does not work at all.

But as for this job. I ended up working out how to program Ecam properly. Its a good program and I would recommend it to anyone on a budget needing a CAD/CAM program. Although I didnt have much to do with the CAD