Hello Guest it is June 19, 2019, 01:42:55 AM

Author Topic: help with MaxNC 10 O.L. 2005  (Read 12638 times)

0 Members and 1 Guest are viewing this topic.

help with MaxNC 10 O.L. 2005
« on: March 27, 2006, 08:16:20 AM »
I have the Max NC 10 O.L. 2005

Pin outs ( seen with a oscilloscope on a dos computer.)

1 .     Spindle Motor     high 5 volts with a variable pulse for speed control 26.5 volts D.C. in off M05.
                                ( +5v with short -5v pulse approx .5 mS for 150 rpm or 32 volts D.C. on Motor
                                  -5v with +5v pulse approx 3.5 mS for 8000 rpm or 100.0 volts D.C on Motor )

2.      A axis          square wave type 20000Hz

3.      A axis          square wave type 2000Hz

4.      Y axis          square wave type 2000Hz

5.      Y axis          square wave type 2000Hz

6.      X axis          square wave type 2000Hz

7.      X axis          square wave type 2000Hz

8.      Z axis          square wave type 2000Hz

9.      Z axis          square wave type 2000Hz

10.    +5v             unknown

11.    +5v

12.    +5v

13.    +5v

14.    +5v          M08  52Hz pulse mist pump ON ( 12volts on Max NC mill connector)
                    M09 +5v no pulse mist pump OFF ( less than .010 volts on mill connector)

15. to 25. unknown

As I don't have a C.L. some pins for limit and home switch's don't apply.

the C.L. setup in Mach 3 may have the right pins for a older model of Max NC C.L. stuff but it don't work
with a Max NC 10 O.L. 2005.

Now when in Max NC Wave Mode in Mach 3  it Still Don't Work.

Pins I see in Mach 3 ( seen with a oscilloscope on a Mach 3 XP computer.)


1. Y axis

2. Z axis

3. Z axis

4. Z axis

5. Z axis

6. X axis

7. X axis

8. X axis

9. X axis

10. ?

11. X axis but a vary low signal on the o scope

12. ?

13.?

14. Y axis

15. ?

16. Y axis

17. Y axis

18 to 25 not connected or grounds

 I can't get the pins to change in Mach 3 no matter what I put in the ports / pins.

 I don't know if Max NC is using pwm for the spindle  on off and speed control but it looks like it.
wave for the steppers and wpm for the spindle the spindle is a DC setup by the way.

 A.C. @ 120v goes to the lighted switch and then to the hot bus ( Wire Nut). From there it goes to a BR61 Bridge
 rectifier in one of the pins marked with a ~ symbol ( A.C ) . the BR61 sends D.C. to the spindle motor from
 the + and - pins on the rectifier. out of the other ~ (A.C.) pin then goes to a s212s01 electronic relay made by Sharp.
 It too has two ~ (A.C.) pins witch one is from the BR61 rectifier that Powers the spindle. The other ~ (A.C.) pin on the
 s212s01 goes to the 120v neutral and completes the 120v side of the spindle
power source.

I hope you all are folling this o.k.

Now the s212s01 has a 1.4v DC ( higher >33 volts under special conditions ) input (from the sharp data sheet) that comes
from the controller. By pulsing the input voltage to the s212s01 ( done in software ) you give the A.C. a intermittant
 on / off state, witch inturn gives a intermittant D.C. output from the BR61 that powers the spindle. and now you have a
 poor mans speed controller. the size of the on versa. off state sets the speed.

short on time = slower speed                        longer on time = faster speed

I do think the pulses from the PC are inverted so pin 1 of the PC will be +5 volts with .5 millisecond 0v pulse
for 150 spindle RPM or 32 volts D.C. on Motor leads.

0v with +5 volts pulse for approx 3.5 mS or higher for 8000 RPM or 100.0 volts D.C on Motor leads.


At the s212so1 will see this on / off state inverted form what the P.C. sent out pin 1 of the port.

Note : the S212S01 is optical witch means it's fast at switching.


So if all this crap above is true, ( my o scope said it is true ) then how do I set up Mach 3 for open loop when Mach 3
 will not let me change the pins in wave mode, and I need to use some sort of pwm for spindle speed control as well as m8
 coolant pump on pin 14 as Mach 3 will only allow m8 on pin 1-6.

By the way - my Max NC controller board says MAX NC CL 10108B , but it does not have the connectors for the encoders or the
 voltage regulator to run them. Since I don't have a C.L. model to read the four 16F84a 20's Pic chips, that are in the
 controller, I can't compare them with the ones in the O.L. 2005 model.

TO Art. There has to be a easer way or a XML file in Mach 3 for all the differant Max NC units. And
i still don't have a clue on getting the spindle to work with the controls in Mach 3. or if Mach 3 even does
control the spindle on and off As well as speed controlling. And forget Trying to use m08 m09 for coolant.

And on the Max NC 10 O.L 2005 the steppers need Mach 3 to output 2000 pulses per unit but the other settings
are the grate unknown to me cause I can't get the steppers to work with z being Z not
 Z for Y as Mach 3 makes it and won't let me change it.

By the way - i have not seen a keyboard chart for the functions in Mach 3, just a hot key settings- what
 are the default keyboard commands? Right now Mach 3 has Pg Up / Pg Dn keys toggling my y axis ( and wrong at that.

.... and I can't change it.

Note: some owners had older models that work, or older mach 3 that worked, but no one is forthcomming with info on the MaxNC boards and the info thats there is out of date for the new 2005 models of O.L. 2005 units.

 :-[

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: help with MaxNC 10 O.L. 2005
« Reply #1 on: March 27, 2006, 08:18:06 PM »
Hi,

Pinouts look the same..
 
I suspect the only difference is ou need ot set the enable lines properly to trigger the motor enables and pic reset lines..

Art