Hello Guest it is May 29, 2023, 01:54:54 AM

Author Topic: Ever had Mach flake out and require a computer restart?  (Read 974 times)

0 Members and 1 Guest are viewing this topic.

Ever had Mach flake out and require a computer restart?
« on: June 27, 2018, 09:51:39 AM »
In the past Mach had been very stable for me, but I'm seeing some weird behavior I can't explain.  It's the same computer as before, and I'm using the current lock-down version.
Here's what it had done lately.
I was using Mach to run a program and my spindle didn't turn on when the S word should have triggered it.  The machine drove the bit into the work. I repeated this several times. I restarted Mach and had the same result.  I shut down the computer and restarted it, and then Mach worked perfectly.

Last night I was running a simple drill program. I homed the machine setup the cut, and hit cycle start. I got a soft limit warning.  This was odd, as I was nowhere near the limits of the machine.  I looked at the part origin I had set moments before, and the origin had moved in Mach.  So I re-homed the machine went through the entire cut setup procedure, and it Mach did it again.  I restarted Mach, went through the same procedure, and Mach did the exact same weird thing.  I then shut the computer down, restarted it, went through the exact same setup procedure, and then it worked perfectly.

Has anyone else seen this kind of strange behavior?

I threatened to change to Centroid Acorn, and I think the Mach Gods are pissed at me. (I really don't want to spend another $465 and learn another system.)

This was the latest program:
N5 G70
N10 T6 M06
N15 S2500 M03
N20 G1 G43 X-.7287 Y-.4185 Z.875 F50. H6 M08
N25 G99 G81 Z.5 R.8027 F1.5
N30 G80
N35 G1 X-.7287 Y-.4185 Z.85 F50.
N40 G99 G81 Z.5 R.85 F1.5
N45 G80
N50 G1 X-.5811 Y.4185 Z.85 F50.
N55 G99 G81 Z.5 R.8027 F1.5
N60 G80
N65 G1 X-.5811 Y.4185 Z.875 F50.
N70 M09
N75 M05

Re: Ever had Mach flake out and require a computer restart?
« Reply #1 on: June 27, 2018, 10:07:18 AM »
Yes, had a similar situation occur a couple of days ago.  Running version 062, ESS, PMDX-126 BoB, W7 64 bit.  I had run several parts with no problems then hit Cycle Start for the next part and the Z drove the tool into the top of the material.  I re-Homed the machine and reset my XYZ machining origin.  Still ran the tool below the top of the material.  Checked my tool table and it was OK.  So I shut down Mach and rebooted my computer.  Ran a few more parts and it happened again.

I think my problem was electrical interference.  I had moved and when setting up my machine I wasn't diligent enough and had run some control wiring next to power cables.  I rerouted the control wiring yesterday morning and ran several parts with no faults.  I think the problem is fixed but only time will tell.