Hello Guest it is October 20, 2019, 12:29:24 AM

Author Topic: Confused on how to address outputs in VB with CSMIO  (Read 2724 times)

0 Members and 1 Guest are viewing this topic.

Confused on how to address outputs in VB with CSMIO
« on: May 22, 2018, 04:26:41 PM »
have been struggling with this for several days now.
I want to control output 3:
So in VB  I Set adn reset Outbit (90,3)
then in ports and pins I set output #3 to port 10 and then pin number 3....


result it works.. Now I change the pin number to 4 assuming that that changes the output pin(terminal) as per documentation
and it does not change, it stays at 3 as before

the strange thing is that #outout 1 and 2 controling the spindle are routed to pin number 12 and 13 in the ports and pins and this works fine

what am i missing...

additional info
it seems that the spindle controll does adhere to the ports and pins pin number, but the VB side does not, it only follows the VB code and that needs to allign with the signal output# number

still confused as the documentation does not explain this verry well




« Last Edit: May 22, 2018, 04:39:58 PM by wantcnc »

Offline Graham Waterworth

*
  • *
  •  1,889 1,889
  • Yorkshire Dales, England
    • View Profile
Re: Confused on how to address outputs in VB with CSMIO
« Reply #1 on: June 01, 2018, 06:45:19 PM »
Cslabs do not use pin numbers they use output numbers so Machs output4 pin number is not Cslabs pin number but the output number on that pin.

So on the Cslabs IP-A device, connection unit terminal 5(out) & 14(return) is output4 so in Mach3 you set output pin to 4

Then in VB you can call  ActivateSignal(OUTPUT4) or DeActivatSignal(OUTPUT4)

Even more confused now?

Without engineers the world stops

Offline TPS

*
  •  1,389 1,389
    • View Profile
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.