Hello Guest it is December 11, 2019, 11:06:58 AM

Author Topic: G2 error code - "Radius to end of arc differs from Radius to start of arc"  (Read 1599 times)

0 Members and 1 Guest are viewing this topic.

I am not sure if this is where i should post.

I am working on my friends simple plasma cutter.  It was running fine until there was a power problem.  My friend did not have a backup.  How many times have we heard of that.  He decided to try and fix it on his own.  I could of done a recovery and had good success.  As he worked through the problems he discovered that the previous owner of the plasma cutter had a hacked version of Mach3.  Friend has since purchased a licensed version.  Friend wiped the computer drive and reinstalled windows 7 and installed the newly acquired Mach3 software.  We are moving in the right direction.

A quick description of his plasma cutter.  It has some unknown Chinese brand stepper motors.  X axis one motor, Y axis one motor and a slave motor on A axis, Z axis.  Plasma Cutter is Hypertherm 65 with THC output.

I have Calibrated X, Y, Z and A.  We are able to cut straight lines, cycle the plasma cutter.  When I try cutting a radius, I get the error code "Radius to end of Arc differs from Radius to start".  I am not sure what program my friend is using to drawn with but he is using Lazycam to develop his g code.  I have searched these forms and have found many possible solutions, most regarding his general setups.  I have have tried to do just one operation of cutting and that is a 1" bolt hole.  Total lines of code perhaps 10 lines.  I still get the error.  When I change the IJ mode to absolute my slave axis A stops working other.

I will deeply indebted to any one that is able to point me to the right direction.

Thanks
Derk

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
IJ mode is likely the problem. Or the g-code is just wrong.
And, IJ mode should have nothing at all to do with your A axis.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Currently my IJ is set to Inc.  Every time I change the IJ to Abs, as I mention in my first post the slave motor stops working.  The slave motor is controlled by the A axis.  When the IJ is set to Inc it errors out on gcode line that G2 the command for the radius.
Gerry,

I have read that perhaps I need to include a G91.1 in my preamble.  You can see my lack understanding regarding my G code skills.  I will post the actual Gcode in an hour or so.

I'm still unclear as to why when I change IJ to abs my slave motor stops working, which is controlled by A axis.

I have for years been going to build a plasma cutter.  If I state from scratch Mach3 or Mach4 serve my needs better?

Thanks

Derk

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
G91.1 just forces Incremental IJ if Mach3 is in Absolute IJ mode.

Changing IJ mode should not stop the A motor from working, so  I can't help you there.

And I've never used a plasma machine, so I don't know which is better.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Could you point me in any direction for additional help?