Hello Guest it is October 20, 2019, 12:18:54 AM

Author Topic: posting problem  (Read 2285 times)

0 Members and 1 Guest are viewing this topic.

posting problem
« on: April 13, 2018, 12:37:08 PM »
I have mastercam x4 when I post a file and load it into mach3 some of the radius on the part are converted into very large arcs unlike the drawing . I double checked the drawing in mastercam and back plot  and it is right but when it gets to Mach3 the radius's not all of them but some of them are changed . has anyone else had this problem and what can I do to fix it ?
Re: posting problem
« Reply #1 on: April 13, 2018, 01:23:49 PM »
Your Cam program post is outputing the arc radius center in the wrong format. The center can be incremental from the start of the arc or it can be in absolute coordinates from the origin you have set.
Re: posting problem
« Reply #2 on: April 13, 2018, 01:29:24 PM »
What setting would this be ??? In the post processor in Mastercam ??
Re: posting problem
« Reply #3 on: April 13, 2018, 02:06:16 PM »
Your Cam program post is outputing the arc radius center in the wrong format. The center can be incremental from the start of the arc or it can be in absolute coordinates from the origin you

I have used this post before on fanuc controlled machines and works fine and the back plot shows it to be fine so I dont understand how the post needs to be changed when it is fine on another machine and on mastercam, this has to be a Mach3 setting
Re: posting problem
« Reply #4 on: April 13, 2018, 06:27:18 PM »
I don’t use Mastercam but you should look to see if you can find a post for Mach 3 specifically. In the bad old days Mastercam made a boat load of extra money for a post processor. So you need to find out if the post processor can be editted. Someone on Practical Machinist site may have a post.

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: posting problem
« Reply #5 on: April 14, 2018, 02:01:35 AM »
I have mastercam x4 when I post a file and load it into mach3 some of the radius on the part are converted into very large arcs unlike the drawing . I double checked the drawing in mastercam and back plot  and it is right but when it gets to Mach3 the radius's not all of them but some of them are changed . has anyone else had this problem and what can I do to fix it ?

I have recently contacted Mastercam regarding their latest Post Processor for Mach3 / Mach4 and their response was to say the least disappointing. Others may have better luck but don’t hold your breath whilst waiting for anything helpful.

Mach3 handles arcs in both Absolute and Incremental Modes and to avoid confusion it’s Gcode should always contain the G90.1 or G91.1 (as appropriate). It is usually the job of the CAM Post Processor to insert these commands but Mastercam does not really bother with Mach so the commands are omitted from their p.p.

You can correct the situation by changing the IJ Mode (Config. / General Config.).  The IJ Mode is a modal setting and once changed will remain but to be certain of avoiding future problems it would be best to add the G90.1 or G91.1 (as appropriate) to the start of all Gcode files containing arcs. The G90.1 or G91.1 should be on a separate line at the start of the Gcode and certainly not share the same line as a G90 or G91.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: posting problem
« Reply #6 on: April 14, 2018, 11:30:16 AM »
I have played around with some of the post files and I came up with using the 3 axis mill post for fanuc control , I will continue to update the post file until it does what I want it to do in mach3 and once I get a good post file I will post it here for everyone to try out . I have been writing post files for Mastercam x4 ever since it came out so maybe by the end of all this we will have a post file that will work . The post I'm using uses r's rather than I and j to cut an arc. To tweakie...yes Mastercam is not very helpful unless u pay a ridiculous amount of money for 1 post file that will probably not work right in the end hints the reason I started writing my own I will keep everyone informed of my progress any pointers or suggestions for posts functions would help