Hello Guest it is September 27, 2020, 10:00:15 AM

Author Topic: Auto zero with ESS not working correctly  (Read 5944 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

*
  • *
  •  8,458 8,458
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Auto zero with ESS not working correctly
« Reply #10 on: April 03, 2018, 02:09:30 AM »
Quote
worked first time exactly right

It will not be ‘exactly right’ because there will always be some overrun (Z axis deceleration at the chosen feed-rate) and that line of code is intended to apply the correction but, if you are happy with the results then that’s all that is important.

Tweakie.
KEEP SAFE !
Re: Auto zero with ESS not working correctly
« Reply #11 on: April 03, 2018, 02:49:15 AM »
Thanks for all the help, I'll probably be back onto ye when the sensors for my homing arrive and I get going on setting them up

Offline TPS

*
  •  1,675 1,675
    • View Profile
Re: Auto zero with ESS not working correctly
« Reply #12 on: April 03, 2018, 03:04:35 AM »
I removed the line "Code "G0 Z" &ZProbePos"

try to replace it by I  "Code "G1 Z" &ZProbePos"

Looks like you machine is not able to follow G0 Speed.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Auto zero with ESS not working correctly
« Reply #13 on: April 03, 2018, 03:30:03 PM »
I changed G0 to G1 and it worked lovely, I've backed up everything so I don't have to try and figure that out again