Hello Guest it is October 18, 2019, 08:29:48 PM

Author Topic: SMOOTH STEPPER SAVED FILES  (Read 2708 times)

0 Members and 1 Guest are viewing this topic.

Re: SMOOTH STEPPER SAVED FILES
« Reply #10 on: March 26, 2018, 10:01:31 AM »
Hi Tweakie:

We're talking the 5th axis (2 in Y) - referred to as the "A" axis.  I was very careful inputting set-up data as you instructed.  As I entered new set-up data, I was careful to delete all data and re-enter it - even if it was the same.  I'm happy that the screens are all identical to the Profile that is working - can't seem to find anything out of the order.  I use the rotary motor (Sherline) quite a bit, but it won't run, even though the DRO does see it as moving.  Nothing shows up abnormally in the Diagnostic Tab.            ?????????????   

Frank

Offline Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: SMOOTH STEPPER SAVED FILES
« Reply #11 on: March 26, 2018, 10:35:17 AM »
Hi Frank,

Can you please attach your .xml file. (Bottom right of the main screen is your profile - look in your Mach3 folder for a file with this name and the .xml extension).
This thread describes making attachments http://www.machsupport.com/forum/index.php/topic,24585.0.html

Your .xml file will enable me to check your settings and hopefully spot the problem.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: SMOOTH STEPPER SAVED FILES
« Reply #12 on: March 26, 2018, 12:57:31 PM »
Tweakie:

How can I best attach or send this file to you -  email address????  I'm new to the forum.
Frank
Re: SMOOTH STEPPER SAVED FILES
« Reply #13 on: March 26, 2018, 01:11:53 PM »
Tweakie:

Let me know if this worked or not.

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: SMOOTH STEPPER SAVED FILES
« Reply #14 on: March 26, 2018, 02:23:13 PM »
Hello Frank,

on a first look to your XML everthing seams to be ok.
you have configurated b-axis as follows:

dir port 1 pin 9
step port 1 pin 8
step's per = 8000
velocity = 79,98
accel =20

Looks like it should move.

can you please post a link or file with the discription of the smoothsteper you are using.

pin9/8 are often used for dublicate funtionality (relays)

Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: SMOOTH STEPPER SAVED FILES
« Reply #15 on: March 26, 2018, 03:49:02 PM »
Hello Thomas
 You're correct with regard to the Y axis.  The angular motor is driven off of the A axis, and is quite different.

Steps Per = 400
Velocity = 799.8
Accel = 400

All of these values match the original profile which does seem to work. 

I don't have much info on the Smooth Stepper as it was installed by the Machine Manufacturer (Velox CNC)  I can tell you that it is the USS version (USB Port) and I believe the model is C25S.  I found them at
Warp9td.com.  I can rip open the controller box and see if I can find something in particular for you if that would help.  Seems very strange that a newly created profile with all the same data doesn't work - but the old one does.

Regards

Frank
 
Re: SMOOTH STEPPER SAVED FILES
« Reply #16 on: March 26, 2018, 07:43:27 PM »
Hello Tweakie:

1) Wanted to let you know I tried to look at the Mach Profile Viewer you sent me.  It did download, but it could not open the program.  I'm sure it is supposed to run on Win7, but I seem to be having a problem with it.   Hopefully I will get back to it some time down the road.

2) While looking at the Profile I generated over the week-end, I noticed the very first line is different.  Under <Profile> <Preferences> <Syskey1>1</Syskey1> ............ my file has <Syskey1>0</Syskey1>.  I'm assuming this is some sort of switch where 1 is on and 0 is off.  Being at the head (start) of the profile, would this be indicative of anything?  There are probably other differences as well but I thought this one might be meaningful.

(Rotary motor works when 1 - does not when 0 )?????????

Regards
Frank

Offline Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: SMOOTH STEPPER SAVED FILES
« Reply #17 on: March 27, 2018, 02:18:42 AM »
Hi Frank,

Couple of things to try...

In Config. / General Config - uncheck B-Axis is angular.

In Config./ Ports & Pins / Output Signals - disable Output#3 and Output#4 (these may cause conflict with the A axis using Port2 Pins 8 &  9).

After these changes have been made and applied Mach3 needs to be closed then restarted.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: SMOOTH STEPPER SAVED FILES
« Reply #18 on: March 27, 2018, 10:54:08 AM »
Hi Tweakie:

Made the changes and re-started but it appears to have had no effect on operation.  Is there a good .XML editor out there that might be employed???  My thinking is that the problem has to be in the .XML  file if everything is working with the old one and not with the .XML file I generated.  Maybe it's time I dumped both files to the printer and then made a line by line comparison.  Your thoughts please....  would certainly be laborious .... but it appears that we don't have many more options.  (or am I barking up the wrong tree)

Regards

Frank

 

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: SMOOTH STEPPER SAVED FILES
« Reply #19 on: March 27, 2018, 11:19:11 AM »
have a look for the link in  Reply #5
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.