Hello Guest it is November 20, 2019, 08:59:28 AM

Author Topic: Mach4 + Pokeys Plugin + Compatible version  (Read 821 times)

0 Members and 1 Guest are viewing this topic.

Mach4 + Pokeys Plugin + Compatible version
« on: July 15, 2018, 05:42:39 PM »
Ok, dopey question.....

https://www.poscope.com/product/pokeys57e/

lists:
Quote
PoKeys Mach4 plugin 8.38.0.3630 + manuals

The changelog within the plugin lists:
Quote
#define POKEYS_MACH4_VERSION      "8.38.0.3630"
#define COMPATIBLE_MACH4_BUILD      "0.3630"

Current Mach4 build is 0.3804...

A quick search of the NFS FTP server unfortunatly does not list 0.3630......

ftp://ftp.machsupport.com/Mach4/DevlopmentVersions/

closest version seems to be:
0.3633

 :-\
which may be about to drop off the end of the list, given it dates from 13 Jan 2018

some Linux distributions run an "LTS" Long Term Support" version which allows for some stability in ever developing distributions....  Would be "nice" if NFS ran such a process..... it may allow for motion controller / plugin developers to base their plugins on an LTS release.

Unresolvable gripe over (NFS issue)

I noticed that there however was not a Mach4 "compatible release" download on the PoLabs site, which I thought there would have been..... given that is the tested / recommended release...... If I was intending to use this for commercial / production, I would have thought / expected that it would be available.

Bit more resolvable gripe with PoLabs (if NeoTO reads this maybe).

Ok..... question.... given the current Mach4 release is 0.3804, are there any issues using this version with PoLabs / Pokeys current plugin release?

Is anything broke between Mach4 current release and the current Pokeys plugin release? .... should I be using a specific Mach4 release that is considered PoKeys stable?

{kind of like with Mach3.... the recommended version with most motion controllers was 0.62, despite the last release (on the NFS site) being 0.66}

Thanks (I'll shoot an email to PoLabs too)
« Last Edit: July 15, 2018, 05:44:33 PM by robertspark »
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: Mach4 + Pokeys Plugin + Compatible version
« Reply #1 on: July 15, 2018, 11:57:29 PM »
Mach4 is in constant development and the team keeps the SDK backwards-compatible. In case of any large changes to the API (very rare lately), PoLabs gets notified and releases the compatible plugin ASAP.
Currently, 3630 plugin is by our knowledge fully compatible with the latest Mach4.
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: Mach4 + Pokeys Plugin + Compatible version
« Reply #2 on: July 16, 2018, 02:42:25 AM »
NeoTO, thanks very much for taking the time and confirming, very much appreciated
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”