Hello Guest it is October 19, 2019, 04:02:54 AM

Author Topic: return called with no sub in effect problem continues  (Read 1139 times)

0 Members and 1 Guest are viewing this topic.

Re: return called with no sub in effect problem continues
« Reply #10 on: February 28, 2018, 02:45:58 AM »
the thing is an RU pendant. it will not work with version over .....50 something. i think the guy who built them had someone else do the plugin and there is no reason or motivation to update it. there is something else i am using or depending on but i forget what it is that requires a minimum of a certain version so i can also not go lower than v ....50 although i would not want to anyway.

i could try dithering around one version up or down but if the only problem i am having right now is that i have to remember to add blank lines to M98s well that is not so bad.

Offline rcaffin

*
  •  1,003 1,003
    • View Profile
Re: return called with no sub in effect problem continues
« Reply #11 on: February 28, 2018, 03:34:03 AM »
Pendant?
I have a pendant which just plugs straight into the USB port. Does it need a plug-in? I can't remember, but at least one eBay vendor says it does not. Maybe it uses a generic one from MS? Anyhow, the whole thing cost me about US$27, and handles 4 axes.

Cheers
Roger
Re: return called with no sub in effect problem continues
« Reply #12 on: February 28, 2018, 11:39:01 AM »
if the pendant does not use a plugin it would have to communicate with mach3 via keyboard commands. i built one that works this way and it works OK in certain respects but it not as versatile as one can be that uses a plugin to directly control mach3. the RU is pretty good but not fantastic but it is an older one.