Hello Guest it is November 15, 2019, 12:49:22 PM

Author Topic: Pokeys57CNC, Pendant, rotary encoder and macro problems in mach3  (Read 2084 times)

0 Members and 1 Guest are viewing this topic.

Pokeys57CNC, Pendant, rotary encoder and macro problems in mach3
« on: February 18, 2018, 04:13:17 AM »
Hello,

I have built a custom pendant with wiring like in the documentation and connected to the pendant connector. I also have added a matrix-keyboard. With the matrix-keyboard I call OEMButtons and on some I call OEMTrig over OEMButton 301.

Everything is working fine, until I use the rotary encoder to move an axis. As soon as the rotary encoder is used, macro execution in mach3 stops working. I can't execute macros. Beeing mapped to buttons in the screenset or over the matrix-keyboard. No macro runs. Only direct calls to OEMButtons work. In screenset and at matrix-keyboard.

When switching to keyboard Jog Mode, macros will run again.

PoKeys57CNC V1.1, Firmware and Software 4.3.8, mach3 plugin from 31.12.17.

Is this behaviour maybe a problem of the firmware, the plugin or a problem of mach3?

Greets

Alex

Offline NeoTO

*
  •  504 504
    • View Profile
    • PoLabs
Re: Pokeys57CNC, Pendant, rotary encoder and macro problems in mach3
« Reply #1 on: February 19, 2018, 12:08:10 AM »
Hi, Alex

Try selecting the option 'Let PoKeys handle MPG jogging' in the plugin settings.
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: Pokeys57CNC, Pendant, rotary encoder and macro problems in mach3
« Reply #2 on: February 19, 2018, 04:39:17 PM »
Hi,
this is set since beginning. I don't have a problem with the rotary and the function of MPG. I have the problem with macros. No single macro will run, when I have used the rotary to move an axis. Beeing it X,Y or Z, 1 step or multiple steps. I have to go back to keyboard movement to be able to run macros again. Seems like when the rotary is used, it blocks macro execution in mach3.

As I have used my parallel-port cable for the Pendant, I cannot recheck the MPG function with a standard parallel-port bob, if it is the MPG function in mach3 itself (or maybe the screenset, but standard functions of mach3 are used), or if it is the PoKeys-plugin.

Greets

Alex