Hello Guest it is October 23, 2019, 05:33:33 PM

Author Topic: Mach3 Error when running G-code  (Read 3231 times)

0 Members and 1 Guest are viewing this topic.

Offline Gordo

*
  •  17 17
    • View Profile
Re: Mach3 Error when running G-code
« Reply #20 on: February 08, 2018, 08:15:08 PM »
I think it must be in the settings in Mach3
Re: Mach3 Error when running G-code
« Reply #21 on: February 08, 2018, 08:37:05 PM »
YUP, there ya go.
That is the "Steps per Unit" setting in motor tuning. And yours is all wrong.
There is an excellent tutorial regarding it in the set-up manual.

Offline RICH

*
  • *
  •  7,368 7,368
    • View Profile
Re: Mach3 Error when running G-code
« Reply #22 on: February 08, 2018, 09:50:06 PM »
Gordo,

I back plotted the circular code from the code you posted. The program as posted runs fine here.
I have attached a picture of the gcode back plotted into CAD and it DOES NOT LIE!.

There are two things that I will candidly say:
1. Read the manual as this stuff is not plug and play.
   You must set the steps per unit correctly for each axis.
   CLick the Settings (Alt 6) tab an in the lower left corner you will see Axis Calibration. Click the Set Step per unit button.
   Follow the instructions by selecting an axis, how far you want to move, say 6", it will then ask you how far it actually
   moved, say it was 5" ( you ACTUALY measure the distance it moved and will also say that the move should be as long as
   possible) , Mach3 will then calculate the steps per unit that it should be. Do it more than once until it's right on.

2. The problem is the operator .......... not the software or the generated gcode. I don't know what you measured in some
    drawing,but, as shown it was not right. Do the above and listen to what folks are telling you and you'll be on your way in
    short order.   

BTW, Please read the manual as one of the first things one does is check their axis for calibration.

RICH


   

Offline TPS

*
  •  1,391 1,391
    • View Profile
Re: Mach3 Error when running G-code
« Reply #23 on: February 09, 2018, 02:48:55 AM »
just in case,
i attached the Manual.

chapter 5.5 and next is your friend.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Gordo

*
  •  17 17
    • View Profile
Re: Mach3 Error when running G-code
« Reply #24 on: February 09, 2018, 08:21:53 PM »
Hi
I want to thank all of you for the help. Just to let you know that I am 72 years old and just build my first machine (Dave Gaton Sidewinder). I do Have the manual but did not understand the formulas to set the pulse rate. I have taken Rich's advice and know the machine is cutting the size that I was expecting.
Once again Thanks for your help and understanding.
Re: Mach3 Error when running G-code
« Reply #25 on: February 09, 2018, 08:35:59 PM »
Congratulations Gordo on a job well done !
When you get that cool lion v-carved, please post a pic of it. I anticipate it being pretty awesome.

Kind regards,
Russ