Hello Guest it is November 21, 2019, 11:58:29 PM

Author Topic: Pokeys pokeying around...  (Read 429 times)

0 Members and 1 Guest are viewing this topic.

Pokeys pokeying around...
« on: June 21, 2019, 12:34:53 PM »
Hi Folks, I have a bit of a dilemma here, when i disconnect the pokeys57cnc board my motors turn smoothly, but when i connect the board they get sticky.
This happen whether they are switched on or off. when i run some code it is randomly jittery and when its all off and i turn the motors by hand they are sticky. I'll attach a short video link that shows the stickyness when everything is swithched off and i turn it by hand.
All the axis do exactly the same, I asked support and they said "When stepper motors are turned, they act as a generator, producing power. When there is enough power generated to turn on the stepper driver control circuit, it will try to take control (stop the motor). This also depletes the power and you are back to almost free running". but that doesnt explain the problem when they are being run by the computer.
Is there something simple i am missing here like a ground or something, any leads or help will go a long way to making my day. Thanks
here's the vid link. https://1drv.ms/v/s!AvolCJeAoVyswy-5qU4Zh9tpmP-r?e=6UT5m0
Re: Pokeys pokeying around...
« Reply #1 on: June 25, 2019, 11:26:29 AM »
So, i found the problem, after a bunch of quite frustrating days, turns out it was something silly. There was no bridge connecting the 5v power supply on the driver from the dir+ to the enable terminal. so if anyone else has this problem just check that.

I have however run into another problem, whenever i start the spindle in mach4, via code or mach4 switch it closes mach4, completely, it just shuts down. I loaded the latest mach4, and it is a 2.2 kw spindle, and PoKeys57cnc

If i switch the vfd off and tell mach4 to start the spindle the relay in the PoKeys board switches on fine.

Any one got some ideas to share. (hope this isn't going to turn into a personal blog)

If i figure it out i'll be back... :-))
Re: Pokeys pokeying around...
« Reply #2 on: June 25, 2019, 03:05:12 PM »
Hi,

Quote
whenever i start the spindle in mach4, via code or mach4 switch it closes mach4, completely, it just shuts down.

How exactly does 'it shut down'? I'm wondering if the VFD or spindle are producing electrical noise that is upsetting Mach.

If you run some Gcode that calls for a spindle start, try running the same code but without the VFD plugged in to the 230V.
With the VFD not powered and therefore emits no electrical noise.....and maybe Mach will keep running.

Craig
My wife left with my best friend...
     and I miss him!
Re: Pokeys pokeying around...
« Reply #3 on: June 26, 2019, 05:56:38 AM »
Craig, yes i think you are correct, i switched off the vfd and ran a code and it was fine, so it must be noise somewhere.

Now for my next trick... anyone have a fast cure for homing issues, my z axis homes, stops reverses as it should then my x axis which has 2 steppers does something different, it hits the switch and motor 1 stops and reverses but motor 2 (Slave) just keeps on trucking.

Why can't it just be easy... ;) ;D

Re: Pokeys pokeying around...
« Reply #4 on: June 28, 2019, 11:29:52 AM »
Ok, so for those who don't know, the solution to my X axis only stopping on one side when homing is this...

"Regarding master and slave axes - the device is designed in such a way that separate home switches are expected on both master and slave axes. If this is not the case, the common switch must be wired to both home inputs (of the master and slave axis) in parallel and configured identically."

Hope that helps someone out there.

The VFD had a short circuit... one on the shielding on one of the cables was touching the cable and shorting things out somewhat, Just stripped it back a little and all good.

Also the shutting down story, I changed the usb to another port and that seems to have fixed that, i was wrong thinking it was to do with the vfd and switching on the spindle on, is was a loose usb connection. when it lost the signal to pokeys it shut down, still not too happy about that tho.

PoKeys support have been pretty good, I'm going through a crash course learning mach4 and pokeys and they have both been patient with me.

Any one have any ideas what this is all about... https://1drv.ms/v/s!AvolCJeAoVyswzHJ_k6cuQfk5prQ its a video showing the steppers stammering somewhat. it happens to all the axis and is quite random. its not losing steps tho i am still tuning the motors, this stopping/interruption/stammering thing has me baffled also.

one day this will all just be easy.
Re: Pokeys pokeying around...
« Reply #5 on: June 30, 2019, 12:00:11 PM »
Ok, So i have figured out what the problem was with the jitters. Turns out some computers don't like the usb setup too much, i switched to the Ethernet cable and it started singing the national anthem, the motors are now running smooth as pie. So the lesson here i think if you are using Pokeys 57cnc and Mach4, then use the Ethernet cable and not the usb. Save yourself 2 weeks of frustration and using words like "darn" and "bugger"... ;))