Hello Guest it is May 22, 2024, 06:53:12 PM

Author Topic: Can't get motion Control Hardware Plugin sensed dialog to appear  (Read 5009 times)

0 Members and 1 Guest are viewing this topic.

I recently added a Pokeys 57E to provide addition I/O capability to my Mach3 setup. I now want to try using the Pokeys stepper driver signals. Try as I might I can't get the Motion Control Hardware Plugin sensed" dialog to appear, so I can select the Pokeys motion control.

I have tried the following:

1) Selecting Function Cfgs|Reset Device selection....... this invokes a message box stating that "You will be asked on next startup what device to use...", however on subsequent startups, the dialog does not appear.
2) I tried deleting PoKeysmachConfig.xml.......same result
3) Completely uninstalled Mach3 as well as Pokeys, deleted all the registry entries and then reinstalled ..... same result
4) Tried using an older version of the Pokeys mach.dll.....same result

Anyone encounter this?
Re: Can't get motion Control Hardware Plugin sensed dialog to appear
« Reply #1 on: January 08, 2018, 01:22:01 PM »
The support staff at Pokeys provided a solution, I'm posting below in case someone else runs into the same issue.

We are unable to replicate the issue you are reporting. We would suggest you the following:
- download the latest 4.3.6 PoKeys setup package (https://www.poscope.com/downloads/)
- update the firmware of the PoKeys device
- restore the PoKeys device to factory defaults by selecting Device > Clear settings in device
- configure the device with a valid IP address
- run 'Troubleshooting' in PoKeys application and check that all is ok (gateway is not needed, discard the warning regarding it)
- delete 'PoKeysMachConfig.xml' from AppData/Local folder
- start Mach3 and add the PoKeys57E device to the plugin configuration, restart Mach3
- start Mach3 and enable Pulse engine in the PoKeys57E device settings, click OK, restart Mach3
- at this point, Mach3 should ask you which motion control device to use