Hello Guest it is July 12, 2020, 04:38:28 PM

Author Topic: Mach4 Button OFFLINE  (Read 13438 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach4 Button OFFLINE
« Reply #60 on: January 27, 2018, 11:59:12 PM »
Hi,
you say that when you enable /disable Mach ENABLE#0 changes state and the relay you've hooked to pin 1 operates.

The macros m210 and m211 turn ENABLE#0 on and off, it should therefore change your relay as well.

If it doesn't then its not ENABLE#0 which the enable/disable button of Mach operates. Can you post a screen shot of the Mach output setup page and a screen shot of the
CSIMO plugin page of pin assignments?

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach4 Button OFFLINE
« Reply #61 on: January 28, 2018, 02:31:24 AM »
Hi,
in the cslab plugin, there are no settings for ports and pins!
with CSMIO, the settings are done ONLY by Mach4.
In the cslab plugin, you can only create special settings related to the CSMIO hardware and its modules (ENC, MPG, etc. Etc.).
possible solution.
it is necessary to reflect ENABLE # 0 on another parallel pin, so it is necessary to make small changes to the macros, adding another output pin.
I will run the servo enable with the second pin via the relay.
Re: Mach4 Button OFFLINE
« Reply #62 on: January 28, 2018, 02:49:26 AM »
Hi,
that sounds pretty rubbishy....you can't assign an output pin to a Mach signal?

There must be a way of having Mach control the digital output pins. If it can't throw it out as rubbish.

If you cannot have Mach run some code and have that code switch output pins on and off or respond to an input its not a controller.
Try Configure/Mach/Output  find ENABLE0 and try to assign it to one of the available output pins of your controller. I can do this with
my eyes closed with my Ethernet Smooth Stepper, you MUST be able to do something similar. Ask CS Labs....they sold it...they should help
you to get it to work.

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach4 Button OFFLINE
« Reply #63 on: January 28, 2018, 03:24:42 AM »
Hi,
reading in the CS Labs section of the forum a few people have had trouble with getting these things to run with Mach4.

http://www.machsupport.com/forum/index.php/topic,35289.0.html

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach4 Button OFFLINE
« Reply #64 on: January 28, 2018, 03:34:28 AM »
in fact they do not work.
I also have poblemi with basic functions, such as the SINGLE BLOCK.
I have already warned of the various problems related to their plugin,
they replied, they are working to resolve.
Given the current situation, I recommend:
I do not want to take advantage of your great kindness and availability (of which I thank you so much).
so, for the moment, I would suspend the topic.
Re: Mach4 Button OFFLINE
« Reply #65 on: January 28, 2018, 03:40:32 AM »
Hi,
how long have you had the device? If it doesn't work make them take it back and give you your money back. You can buy an ESS for
half what they want and it works.....having electronic devices that work are very handy for CNC!

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach4 Button OFFLINE
« Reply #66 on: January 28, 2018, 03:46:49 AM »
I have had CSMIO for about 1 year.
with Mach3 everything works fine.
but I bought Mach4 license for evolution, and also because I like it a lot.
but if it does not work, I'll have to find a solution, or change software, I have no alternative.
I try to wait a little longer, then I will make a decision!
Re: Mach4 Button OFFLINE
« Reply #67 on: January 28, 2018, 03:59:05 AM »
Hi,
I would be leaning on CS Labs....they are the ones advertising that their device is Mach4 ready and its not.

Tell them to fix it or give your money back. You might remind them that as a member of the forum that you are in a position to tell a wide
audience that their device does not work and/or that they are not prepared to help you.

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach4 Button OFFLINE
« Reply #68 on: January 28, 2018, 04:13:35 AM »
absolutely no! they are very kind and helpful!
then I absolutely do not want to escapist possibility that I am unable to configure optimally!
in my opinion, there is only to be a bit of patience, and solve the problems, I find a serious company.
Rather..
I open only little off topic.
on the pantograph it has the SSE + C25.
I wanted to try out of curiosity Mach4.
I found myself faced with this problem.
I attach link video dropbox.
https://www.dropbox.com/s/zjhvt4z03yovjsn/20171102_090430.mp4?dl=0
sorry for in, bad english ..! i'm italian :-)
can you indicate me where to look for a pantograph solution?
Re: Mach4 Button OFFLINE
« Reply #69 on: January 28, 2018, 04:43:30 AM »
Hi,
well if I had spent that sort of money and it didn't do what the company claimed I would be hammering them for a solution.....that's a plain rip-off.
That however is your call.

If you want to run Mach4 I suggest CS Labs offering is too immature. I have no reason to doubt that they will get there in the end and they have a good
reputation in the Mach3 market but it sounds like their Mach4 stuff is s*********t.  CNCDrive, another European manufacturer also with a good reputation in the
Mach3 market but has only been in the Mach4 market a few months. I wouldn't go there either....I want something that works from the very start.

https://warp9td.com/
https://www.poscope.com/
https://www.pmdx.com/
http://www.vitalsystem.com/portal/index.php

All of these companies have been making and selling Mach4 stuff for quite a while. That's where I'd be going.

I've watched your video but not quite sure what you are trying to show me. If its the fact that the machine cant jog two axes at once that's because they can't.
To do that requires coordinated motion ie Gcode or Gcode as MDI.

Craig
My wife left with my best friend...
     and I miss him!