Hello Guest it is December 09, 2019, 12:49:45 AM

Author Topic: Connection between button function and script  (Read 1566 times)

0 Members and 1 Guest are viewing this topic.

Re: Connection between button function and script
« Reply #10 on: November 23, 2017, 03:04:39 PM »
What screen set are you using? Make sure you go to "load Screen" and load up the wx4.set screen.
Once in here you should get a pop up with the probing stuff when you hit touch.
Re: Connection between button function and script
« Reply #11 on: November 23, 2017, 03:23:38 PM »
Hi,
the Touch Module is included with the last several builds of Mach.

Go to the help tab and find the build number currently installed.

Craig
My wife left with my best friend...
     and I miss him!
Re: Connection between button function and script
« Reply #12 on: November 23, 2017, 04:06:19 PM »
wx4.set, using 3 axis and ver 3481
Re: Connection between button function and script
« Reply #13 on: November 23, 2017, 04:39:25 PM »
Hi,
well that is certainly the latest build, and the Touch module is included. I think the problem may be because the use
of Demo. My understanding is that the Touch module doesn't work with Demo.

Do you have a licence for Mach4? I'm also not sure that the Sim motion controller will work with Touch, after all
how can you simulate a probe strike? Darwin can probe OK but not sure whether it supports all the Touch functions.

Craig
My wife left with my best friend...
     and I miss him!
Re: Connection between button function and script
« Reply #14 on: November 23, 2017, 05:17:47 PM »
Hi
I do have a license, but noticed that its gone to Demo mode, not sure if that happened when I installed 3481??, as luck has it I have tried to update my license on the site but that has gone pear shaped, so waiting for an email response.

Getting to better grips with this, so changed the code to remove the A0 axis and the go to working zero works brilliantly, but the ref all now just locks up till I press stop, LEDs dont change and nothing moves.