Author Topic: Servo Newbie Needs HELPPPPP  (Read 2498 times)

0 Members and 1 Guest are viewing this topic.

Offline Third-Gen

  • Active Member
  • Posts: 18
    • View Profile
Servo Newbie Needs HELPPPPP
« on: October 28, 2017, 11:39:05 AM »
Hey all, first time poster long time Mach user. Have multiple Mach3 machines running stepper setups, easy to use and basic. Came across some old automation equipment for a STEAL the other day, and got a ton of Servo stuff. I have a bunch of Parker Aries drives and Servos, and some Mitsubishi stuff too, which ill use later. I then realized I needed motion controller, so Ebay netted me a DMC-1760 ISA card, with the hard drive and MOBO, and also came with a ICM-1900 breakout, not the one in the enclosure, just the bare board with the screw terminals.

Ive looked, and looked, and looked. I can get Mach to talk to the board, its configured with the drivers, etc. But I have ZERO ideas how to wire this and actually get it to move. Ports and Pins is my downfall here. I got the encoders hooked up, but it looks like my drives only take a Torque+ and Torque- (labeled AIN+ and AIN-) to do the commands. Ive set the drives to torque only mode with the Parker software, and If i plug AIN+ and AIN- to any of the outputs (PWMX, MODX, SIGNX, etc) it just goes wide open full rpm. I can vary the voltage going to AIN+ and it adjusts the speed (which is correct) but I cant get the board itself to do it.

Anybody have any ideas? Im at a loss right now. Ive looked through a TON of PDFs and short of just trying random stuff, Im open to advice.

Offline Third-Gen

  • Active Member
  • Posts: 18
    • View Profile
Re: Servo Newbie Needs HELPPPPP
« Reply #1 on: October 28, 2017, 11:44:57 AM »
wow, literally 3 minutes later i have movement, oy. still lots to learn!