Hello Guest it is May 20, 2019, 03:08:50 PM

Author Topic: Erratic Feedrate When Cutting Spline Lines  (Read 4168 times)

0 Members and 1 Guest are viewing this topic.

Re: Erratic Feedrate When Cutting Spline Lines
« Reply #40 on: October 01, 2017, 01:49:24 AM »
I'm pretty new to Mach4 so forgive me if this is obvious to everyone but me. I don't want to break anything on my setup so I'm perhaps being overly cautious.

Right now I just have CV turned on in the main Mach4 config. Not in the CV Wizard. Am I correct in assuming that this will provide a generic CV profile that Mach will use?

When I install the 2 files that Chaoticone provided into the Mach4 Wizards folder and run it like any other wizard it will populate the Wizard CV table with more optimised settings based on what I input, and if I check "Use CV" here then it will use these figures? If I uncheck the box then it goes back to the generic CV from the main Config?

Is it advised to copy my profile and work with the copy when I'm doing something like this?

Online Chaoticone

*
  • *
  •  5,493 5,493
  • Precision Chaos
    • View Profile
Re: Erratic Feedrate When Cutting Spline Lines
« Reply #41 on: October 02, 2017, 04:38:48 PM »
Quote
Right now I just have CV turned on in the main Mach4 config. Not in the CV Wizard. Am I correct in assuming that this will provide a generic CV profile that Mach will use?

Not really, the only thing that setting does in general config is set the default mode to CV or exact stop. When you fire up Mach or click the reset button it sets things to a default state. In regards to this, it activates default modal codes (G64 or G61).

Quote
When I install the 2 files that Chaoticone provided into the Mach4 Wizards folder and run it like any other wizard it will populate the Wizard CV table with more optimised settings based on what I input, and if I check "Use CV" here then it will use these figures? If I uncheck the box then it goes back to the generic CV from the main Config?

Not necessarily. To use the values generated by the wizard the api call mc.mcMotionSetCVAngleEnable has to be called. When you go through the mcCvTuningWizard this call is executed to enable it. In the CV_Feedrate wizard (table) you can enable or disable it by toggling the button up top. I can't think of a reason anyone would want to turn it off (because exact stop mode ignores it all together anyway) but good there is a call to control it through script if you had a need to.
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline dq828

*
  •  57 57
    • View Profile
Re: Erratic Feedrate When Cutting Spline Lines
« Reply #42 on: October 05, 2017, 10:44:01 PM »
Is any of this information written in a Manual somewhere, seems like very important info to me?
Re: Erratic Feedrate When Cutting Spline Lines
« Reply #43 on: October 06, 2017, 03:03:31 AM »
Hi dq282,
regrettably manuals always seem to be some years behind the forefront of Mach4. This does cause lots of consternation but that's the way it is
and unless Artsoft start charging us bigtime its not going to change dramatically for a good while yet.

On the other hand your original post and all the replies, ancillary questions and comments are all available for anyone to follow. The forum IS
the manual.

Craig
My wife left with my best friend...
     and I miss him!