Hello Guest it is April 16, 2021, 11:07:30 PM

Author Topic: All the Gear and No Idea (as to why nothing happens)  (Read 5485 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

*
  • *
  •  8,695 8,695
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #30 on: September 04, 2017, 11:27:04 AM »
Excellent guitar work (I shall keep very quiet about my guitar playing  ;)).

Try initial set-up as attached.

Is Estop working ?

Pressing the Red Button on your controller should make the Mach3 on-screen Reset button flash red/green boarder. Releasing the red button on your controller (and clicking the on-screen button) should make the Mach3 on-screen button have a steady green boarder.

Tweakie.
« Last Edit: September 05, 2017, 01:01:42 AM by Tweakie.CNC »
KEEP SAFE !
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #31 on: September 04, 2017, 03:28:37 PM »
Thanks Tweakie, Just in from a hard slog of a day in the workshop catching up on back orders, polishing 'Polyoxymethylene' is a pig because it melts at 160 degrees. :o. I'll try those settings now..Regarding guitar, consider that I may have a slight advantage over you, I've been full-time Pro for just 60 years. ::)
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #32 on: September 04, 2017, 04:00:18 PM »
OK ! Kudos to you 'Tweakie'.. It's working, but no control of spindle speed and the X,Y,Z movement is very slow. I loaded the <TestCircle.tap> and it took 11 minutes and 7 seconds to do half.?
BUT <roadrunner.tap> took just 4 min. 54 sec.
« Last Edit: September 04, 2017, 04:11:14 PM by basilhenriques »

Offline Tweakie.CNC

*
  • *
  •  8,695 8,695
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #33 on: September 05, 2017, 01:13:49 AM »
Hi Basil,

The next step is to decide if you will be working in Metric or Imperial units and calculating your Steps per Unit - there is a calculator here;  http://www.machsupport.com/forum/index.php/topic,16315.0.html

Once that is done then fine tune everything (setting Velocity & Acceleration in Motor Tuning) to obtain best and 100% reliable performance.

All this is best done with reference to the Mach3 manual as I have only mentioned the basics here.

Tweakie.
KEEP SAFE !
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #34 on: September 05, 2017, 06:29:14 AM »
Thanks 'Tweakie', ATPIT I have no control over spindle speed except for the knob on the control box ? ??? ???
If I can just get that sorted so that Mach3 has control of the spindle then the calibration etc SHOULD be a doddle..I will report upon my progress as and when.



Steel Players do it without fretting!

Offline Tweakie.CNC

*
  • *
  •  8,695 8,695
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #35 on: September 05, 2017, 06:50:10 AM »
Hi Basil,

I am not certain that your control box contains a spindle on/off relay (at least it cannot be seen in the photo's) and the port and pin data you posted earlier does not mention spindle control. I think you may only have manual spindle control at this moment in time.

Can you see a relay ?

Tweakie.
KEEP SAFE !
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #36 on: September 05, 2017, 06:53:26 AM »
I'll check later, BTW the emergency stop knob operates in a counter intuitive way. I'm used to pushing in the safety knobs on machines to STOP them, this has to be in, and in an emergency you have to twist it and it pops out. OMG just as well we're talking about machinery isn't it !  >:D
« Last Edit: September 05, 2017, 06:55:31 AM by basilhenriques »

Offline Tweakie.CNC

*
  • *
  •  8,695 8,695
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #37 on: September 05, 2017, 07:11:53 AM »
Hi Basil,

Config. / Ports and Pins / Input Signals / EStop - change the Active Low to a tick. That should reverse the operation to how it should be  ;)

Tweakie.
KEEP SAFE !
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #38 on: September 05, 2017, 08:20:58 AM »
Hi Basil,

Config. / Ports and Pins / Input Signals / EStop - change the Active Low to a tick. That should reverse the operation to how it should be  ;)

Tweakie.
OK Thanks..
Regarding Spindle AND 4th axis. No relays anywhere in the control box, there is a front mounted on/off for the spindle and a potentiometer controlling the variable speed. There is a separate pcb for the spindle AND it just has positive and negative volts out. (Two wires to the spindle) The control of the 4th axis is on a separate board I haven't checked its function yet.
How do I check it ? G-code ? or what ..
Up until now I was under the impression that "Chinese Junk" was a boat, this boat don't float !
« Last Edit: September 05, 2017, 08:26:19 AM by basilhenriques »

Offline Tweakie.CNC

*
  • *
  •  8,695 8,695
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #39 on: September 05, 2017, 10:42:11 AM »
Hi Basil,

You perhaps need more details from the supplier of your controller regarding spindle control but my guess is that it is just manually operated.  

If your 4th axis (A axis) is connected and not Inhibited within Mach3 (Settings (Alt-6) page) then you should be able to control it’s rotation from the MDI (Alt-2) page.
For example Input…
F500
G0 A100
(Pressing Return after each entry).
The axis should now rotate 100 units.
The A axis has to be set-up with steps per unit Velocity and Acceleration in Motor Tuning like the other axis etc.

Hope this helps.

Tweakie.
KEEP SAFE !