Hello Guest it is November 20, 2019, 04:42:27 PM

Author Topic: Loosing steps on the Z?  (Read 986 times)

0 Members and 1 Guest are viewing this topic.

Loosing steps on the Z?
« on: August 24, 2017, 10:56:48 AM »
Hi guys. I have just bought a new to me Chinese machine stepping up from a Shopbot and have been cutting with it for some time now with no issues. Just 2D stuff. Recently I've been giving my hand a try to make a carved door for my house from 3d model I made from a grayscale modeled in Aspire. It's a very large file and is 4 passes roughing. I've noticed that the Z is rising over the with of the 30"model about 1/4 to 3/8 of an inch. I've ruled out the obvious things like hold down, collet slipping and software.  Everything looks as it should in the preview. I'm down to thinking I'm just loosing steps. I'm not very skilled on Mach as of yet but I did notice the Kernel rate is set as it's highest setting. Should the 4 GB computer computer that came with the machine already configured be able to handle that speed without loosing steps. I know nothing about tuning motors and am a little hesitant on doing it since I really can't deal with the down time right now, but is is what it is at this point.  Thanks in advance
Re: Loosing steps on the Z?
« Reply #1 on: August 24, 2017, 11:20:34 AM »
Does it do this when you're carving nothing?  If so, possibly lost steps.

Motor config is very easy.  Just go to config>motor tuning and then change your velocity down and your acceleration down.  For instance my machine came with a velocity of 750 ipm and acceleration of 20 in/sec/sec.  So I just went to 500 ipm and 10 in/sec/sec.  Do the same and just run the machine and see if you like how it moves.  These are the settings for my x and y and my z axis velocity is a little less than that.

If it doesn't do it while carving nothing, the first thing I would try is do you have the z axis well lubricated?

May have to make more passes at it?  Dull tooling?

Offline Tweakie.CNC

*
  • *
  •  8,006 8,006
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Loosing steps on the Z?
« Reply #2 on: August 25, 2017, 01:58:09 AM »
In addition to what has already been said...

Assuming you are using the parallel port then set the Mach3 Kernel Speed to the lowest setting that enables your desired motor's Velocity to be achieved.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Loosing steps on the Z?
« Reply #3 on: August 25, 2017, 07:35:06 AM »
Thank you for the replies. I'm going to do a test air cut today to help with the diagnostic process. My tooling is new and and the Z axis is well lubed. It's ball screw. Very tight and no noises or play. If it's not loosing sets i'm going to start leaning toward settings. It's awfully consistent so I'm starting to lean that way.
https://www.facebook.com/FishingCreekMillwork/photos/a.634315226601813.1073741830.634308399935829/1311348348898494/?type=3&theater
Re: Loosing steps on the Z?
« Reply #4 on: August 25, 2017, 05:52:08 PM »
Hi,
steppers lose torque the faster they go. You can try to counteract that by using high voltages to drive them but it seems that 80V is about the limit
for readily available drivers.

The graph attached shows a fairly typical two phase 23 size stepper rated at 198 oz.in. You can see by 500 rpm the pullout torque is reduced to about
half and by 1000 rpm down to about a quarter of rated torque.

On the Tormach website there is a clip where they assign the max speed to any stepper of 375 rpm to ensure that the torque remains high enuf for reliable
motion, ie without losing steps. Tormach are quite conservative. I regularly think that 500 rpm is a reasonable compromise.

If your machine has a 5mm pitch screw then at 500 rpm that works out to 2500 mm/min or about 100 in/min. With a 10mm pitch screw that would be
about 200 in/min but remember a 10mm pitch screw is going to need twice the torque to drive it...you may be in danger of exceeding the pullout torque
of the stepper and create a stall.

Stepper motors are great at slow speeds, in terms of 'torque density' they are better than a servo of the same size. As the speed gets up that's where servos are
come into there own. Downside is that servos, even cheap ones are much more than a stepper. Don't lose hope though...many CNCers use steppers with great
results.....just be aware that there is a speed limitation.

Craig
My wife left with my best friend...
     and I miss him!
Re: Loosing steps on the Z?
« Reply #5 on: August 26, 2017, 09:55:09 AM »
Ok I ran the same file with the spindle of for about an hour then rechecked the z. It raised about 1/8". Any suggestions guys? The Z seems tight. Setting?
Re: Loosing steps on the Z?
« Reply #6 on: August 26, 2017, 12:27:17 PM »
Hi,
try reducing speed and acceleration to half of current settings and try again. If it solves the problem you'll know that the problem is lack of torque
on Z axis motor. If it doesn't solve it then I would be looking at an electrical/mechanical issue.

Craig
My wife left with my best friend...
     and I miss him!