Hello Guest it is October 20, 2019, 05:40:09 AM

Author Topic: Downloaded Mach4-2.0.3481 Hicon plugin won't load  (Read 1823 times)

0 Members and 1 Guest are viewing this topic.

Downloaded Mach4-2.0.3481 Hicon plugin won't load
« on: September 02, 2017, 05:14:27 PM »
I just upgraded Mach4 and the Hicon plug in won't load.
I have down loaded the latest plugin for Mach4 from the Vital website and updated the control.
When i start the latest version of M4 i get an error that says:
Failed to load shared library 'M4HICON.m4pw' (error 0: the operation completed successfully)

Needless to say i don't have the control available for use.

Thanks
Glenn
Re: Downloaded Mach4-2.0.3481 Hicon plugin won't load
« Reply #1 on: September 02, 2017, 09:37:32 PM »
Hi,
I don't know anything about HiCon I'm sorry but when you downloaded the plugin there should have been two files
M4HICON.m4pw
but also
M4HICON.sig

The last file is some sort of digital signature that is supplied to Vital Systems by Artsoft as an approved developer and the plugin wont work without it.
Have a look in Mach4Hobby/Plugins and see if both files are there.

Craig
My wife left with my best friend...
     and I miss him!
Re: Downloaded Mach4-2.0.3481 Hicon plugin won't load
« Reply #2 on: September 03, 2017, 10:40:14 AM »
Craig
The .sig file is in there. 
Because my previous install of Mach4 was May 2015 and i decided to start doing some probing i upgraded.
Looks like is was working under 3390 but i couldn't find that install so used the latest.

For the time being i went back to the older version until i can get it figured out.
Glenn

Offline Mauri

*
  •  306 306
    • View Profile
Re: Downloaded Mach4-2.0.3481 Hicon plugin won't load
« Reply #3 on: September 04, 2017, 05:04:41 PM »
gadman58,
I tested the 3481 Plugin and it or mach4 3481 has an issue it stops during a cutting run.
Vital Systems were testing as well.
Plugin 3481 is not released yet and you cannot use OLDer HiCON plugins on new Mach4 (3481) releases.
Regards,
Mauri.