Hello Guest it is June 25, 2019, 08:47:36 PM

Author Topic: No rpm display on mach3 turn  (Read 622 times)

0 Members and 1 Guest are viewing this topic.

No rpm display on mach3 turn
« on: August 12, 2017, 05:38:52 PM »
Hi
Have been running mach3 on 3 machines for 6 years with no problems
We had a bad power surge during a storm that took out 2 of our computers and damaged one of the breakout boards,
Have renewed the computers which now have windows 7 32bit instead of XP
Have now renewed the breakout boards and drivers  on the lathe,
Everything is working fine the home switches, estop , and coolant pump
But no index display
in diagnostics screen the green index is flashing slowly,
I am using a hall effect switch with magnet on the spindle on test the switch is going from 5volt to .23 volt on the magnet pass
This has always worked well
I have also renewed the switch and cables to the bob
At our wits end at the moment
Any help or suggestions will be appreciated
Could it possibly be windows 7?
On driver test mach 3 says all ok
Colin

Re: No rpm display on mach3 turn
« Reply #1 on: August 13, 2017, 06:45:42 AM »
You may not have assigned the Index pulse to the right pin - or you may have an open circuit, or you may have huge filtering in place.
Start tracing the signal from the Hall effect Sw back to Mach. Every inch of the way.

Cheers
Roger

Offline RICH

*
  • *
  •  7,338 7,338
    • View Profile
Re: No rpm display on mach3 turn
« Reply #2 on: August 13, 2017, 06:46:45 AM »
Click the spindle button?

RICH
Re: No rpm display on mach3 turn
« Reply #3 on: August 13, 2017, 01:29:07 PM »
Thank you guys for your prompt reply
Have rechecked the pin number and port
Even assigned it to a pin that I know is working
Have run new cables direct to the input pin on the bob
I have zero volt from 5 volt on magnet pass
When running g code mach does not give the fault (no rpm detected) but it will not complete the program
And tried clicking the the spindle button
I do not know about filtering or where to look
I must be missing something
Thank you
Colin