Hello Guest it is October 21, 2019, 07:14:04 PM

Author Topic: Triple edge zero finding plate problems  (Read 3051 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

*
  • *
  •  7,955 7,955
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Triple edge zero finding plate problems
« Reply #10 on: August 03, 2017, 02:33:54 AM »
Hi Ian,

Your .xml file is in your Mach3 folder and it is called    Mach3Mill.xml

On the attached image I have marked pin 13. Is this the pin you are using ?

By changing the Mach3 Probe configuration (different pin) do any of the other inputs (pins 10,11,12) work ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Triple edge zero finding plate problems
« Reply #11 on: August 03, 2017, 06:41:20 AM »
Hi,

Yes that is the pin I am using Pin 13.

All the other pins are in use. Pins 10,11 and 12 are connected to my limit switches for x axis, y axis, and z axis and all work fine.

I am struggling with the .xml file, but i've sent it directly to your website again.

Thanks
Ian

Offline Tweakie.CNC

*
  • *
  •  7,955 7,955
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Triple edge zero finding plate problems
« Reply #12 on: August 03, 2017, 07:27:28 AM »
I think we have now covered all the possibilities and my conclusion is (as you suspected) the breakout board Pin 13 is bad.

Limit switches do not need separate inputs (except for slaved axes) so they can share just one Input pin. This could free up a working Input for use with your Probe. Alternately, a new (perhaps better quality) breakout board is required ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Triple edge zero finding plate problems
« Reply #13 on: August 04, 2017, 04:34:32 AM »
Thanks once again for your reply.

I think we have both come to the same conclusion- time for a new board replacement.!!!

Can't thank you enough.
ian

Offline Tweakie.CNC

*
  • *
  •  7,955 7,955
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Triple edge zero finding plate problems
« Reply #14 on: August 04, 2017, 05:29:57 AM »
Hi Ian,

Thank you for your kind words.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Triple edge zero finding plate problems
« Reply #15 on: August 14, 2017, 06:47:23 AM »
Hi Tweakie,

Well one week on and i'm pleased to report that I have replaced the board with a more recent model and all is working fine.

As you will remember the problem arose when I found the script from Allen Massey to use a triple edge finder. Well that is working fine too after much head scratching altering the script from imperial measurements to millimetres to suit my machine.

You offer a great service, much appreciated.
Ian

Offline Tweakie.CNC

*
  • *
  •  7,955 7,955
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Triple edge zero finding plate problems
« Reply #16 on: August 14, 2017, 06:59:11 AM »
Hi Ian,

I am pleased to hear that all is now working well and congrats on converting that script from Imperial to Metric  ;)

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.