Hello Guest it is October 27, 2020, 11:07:31 PM

Author Topic: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem  (Read 9052 times)

0 Members and 1 Guest are viewing this topic.

Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #10 on: July 25, 2017, 09:55:52 AM »
The M542 stepper drivers I'm connecting at the moment can handle pulse frequency between 0 and 300khz. Pulse width not less than  1.5us. I'm not certain what the csmio ips puts out.
Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #11 on: July 25, 2017, 07:25:47 PM »
I am experiencing the same issue with the IP-M and Mach4. I am using the latest 3.01 firmware and have tried a number of things to solve the issue with no luck:

1. Downgrading the firmware to the latest non beta version (2.910). This firmware/plug-in seems to be incompatible with the current release of Mach4 as I was unable to connect to the device using this firmware.
2. Restarting the device after making changes to the steps/unit parameter within Mach4. This appears to have no effect.
3. Changing to a developmental release of Mach4Hobby (in this case version 4.2.03418.) This also had no effect.
4. Changing the micro-step resolution of my stepper drives (Leadshine EM806) from 1600 to 400 steps/rev. This had the effect of increasing the distance traveled - presumably by 4x. However, the steps/unit parameter still had no effect.

If I had to guess I would say that the current BETA version of the CSMIO firmware package is bugged. I would be more than happy to use the 2.910 firmware or earlier to fix the issue (as CS-lab themselves recommend) however none of these firmwares seem to work either. I have attempted to contact CS-lab support regarding this issue but have yet to receive a response.

Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #12 on: July 26, 2017, 10:13:33 AM »
The M542 stepper drivers I'm connecting at the moment can handle pulse frequency between 0 and 300khz. Pulse width not less than  1.5us. I'm not certain what the csmio ips puts out.

Sure you do (assuming the following quote is accurate).

Quote
Csmio pulse duration is %50

So do the math using your steps per and velocity to determine how many pulses a second your asking CSLabs to send. If it is less than the CSMIO/IP-M's maximum freq. do the math to determine if the duration is within the drives requirements.
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #13 on: July 26, 2017, 04:24:08 PM »
e.nc

If you need to revert to plugin 2.910, it might be worth winding Mach4 back to version 4.2.3233. I use the IP/A but find that 2.910 is incompatible with newer versions of Mach4 than 3233, so the same may apply to the IP/S.

Allan
Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #14 on: July 26, 2017, 04:44:00 PM »
e.nc

If you need to revert to plugin 2.910, it might be worth winding Mach4 back to version 4.2.3233. I use the IP/A but find that 2.910 is incompatible with newer versions of Mach4 than 3233, so the same may apply to the IP/S.

Allan

Thanks for the info Allan, any idea where I could find version 4.2.3233? I can only see versions 3390 or higher on the Mach4 downloads page/FTP server.

Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #15 on: July 26, 2017, 05:03:04 PM »
Quote
Thanks for the info Allan, any idea where I could find version 4.2.3233? I can only see versions 3390 or higher on the Mach4 downloads page/FTP server.

http://www.pmdx.com/Downloads_Mach4/Mach4_Hobby_Releases/Mach4Hobby%20Installer-4.2.0.3233.exe
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #16 on: July 26, 2017, 05:16:27 PM »
Quote
Thanks for the info Allan, any idea where I could find version 4.2.3233? I can only see versions 3390 or higher on the Mach4 downloads page/FTP server.

http://www.pmdx.com/Downloads_Mach4/Mach4_Hobby_Releases/Mach4Hobby%20Installer-4.2.0.3233.exe

Cheers!
Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #17 on: July 28, 2017, 02:17:08 PM »
Just writing to confirm that lowering the firmware to 2.910 with Mach4.3.3233 fixes the issue. Hopefully the CS-Lab guys can patch the new firmware to work with the latest Mach4 release, in the interim I would suggest using this fix.
Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #18 on: July 28, 2017, 06:02:25 PM »
e.nc

Glad you got it working. I find that this combination generally works well with my CSMIO-IP/A but it can sometimes freese Mach4 during probing cycles. When Mach4 freezes, the probe does not move, so there is no chance of damage to it.

Allan
Re: CSMIO/IPS MACH4 "Counts per unit"/DRO Problem
« Reply #19 on: August 13, 2017, 06:05:42 AM »
Hello,

i have same problem. CSMIO IP-M Controller and Mach4. The Firmware v2.910 works only with Mach4 4.2.0.2803. With newer Mach4 versions, i get no connection to the controller. Then i tried the CSMIO v3.01 beta with Mach4 v4.2.0.3390 or v4.2.0.3418 but there is a other problem: when jogging in mm, the distance in mach4 does not coincide with the real. Changes of the steps per unit at Motor settings has no effect. The controller always outputs 1000 steps per mm.
The CSLAB support means it is a bug of Mach4.
« Last Edit: August 13, 2017, 06:09:38 AM by HeadyCS »