Hello Guest it is November 12, 2019, 12:59:16 AM

Author Topic: PoKeys57CNC, feedrate in Mach4 incorrect  (Read 1392 times)

0 Members and 1 Guest are viewing this topic.

PoKeys57CNC, feedrate in Mach4 incorrect
« on: March 29, 2017, 05:39:27 PM »
Here is something for the lathe thread cutters and mills:

Now everything (except of probing with G31 on my mill, but that is a different topic) runs with PoKeys57CNC. Motion is very smooth, limit switches working, PWM, ... but the feed rate on both of my machines runs never as commanded. When I command in the G-Code (metric, G21) G1 X10 F10, it will run the x-axis with 6.40 mm/s instead of 10 mm/s. I also tried it with inch settings, but with the same result. Weird!

The FRO is set to 100% (sure, I can get the feedrate to the desired 10 mm/s if setting the FRO to 156%, but that is not the point).

This behavior is totally reproducable and independant from settings like exact stop, css or whatsoever. I clocked the motion with a stopwatch and indeed, it takes this strange factor of 1/0.64 = 1.56 longer as desired to drive (any axis) a certain distance.

This is very annoying, especially when I want to cut threads on my lathe (because during threading, the FRO is locked to 100%).

And, yes, I could work around with generating G-Code which commands the CNC always this 1/0.64 factor faster than desired, but that is obviously not the way to do it.

Has somebody seen the same or an solution for that?


Offline N4NV

  •  393 393
    • View Profile
Re: PoKeys57CNC, feedrate in Mach4 incorrect
« Reply #1 on: May 23, 2017, 11:55:38 AM »
Did you ever find a solution?

Re: PoKeys57CNC, feedrate in Mach4 incorrect
« Reply #2 on: August 19, 2017, 03:31:42 PM »
I just want to update the community:

The Mach4 update solved the issue, all axes are running now at nominal speed now. That obviously was something in the mach4 kernel in combination with Win XP...

Topic can be closed!