Hello Guest it is June 16, 2019, 01:29:11 AM

Author Topic: Help! Mach 3 glue dispenser !!  (Read 828 times)

0 Members and 1 Guest are viewing this topic.

Help! Mach 3 glue dispenser !!
« on: July 22, 2017, 06:45:35 PM »
Hi All,

I am new to the forum and I have a question about an unusual application which I hope someone can help me with.

I have a CNC glue dispenser set up so that it dispenses adhesive following a vector with Mach3. The dispenser is activated using M3/M5 and it dispenses glue after the Z plunge and stops dispensing as the Z axis rises.
The problem is that there is a small dwell before X,Y move:

N290G1M3Z-0.100F480.0   <----- Here
N300G1M3Y64.994F6000.0
N310G1X55.873
N320G1Y2.436
N330G1X1.411
N340G00M5Z3.000

As you see, the post processor is set to give M3 at first 'begin FIRST_FEED_MOVE', but by the time the X,Y axis start moving, there is fraction of second delay which means the glue starts to pool before the X,Y axis have started to move.

So, I thought to provide the glue pump activation relay with a signal ONLY if X OR Y are moving AND M3 is active but where to get that signal from? i.e I would need a pin "high" indicating X or Y move and 'low' at any other time so that I could logically AND this to M3 (which outputs at pin 17).

Any ideas appreciated :-)

Re: Help! Mach 3 glue dispenser !!
« Reply #1 on: July 22, 2017, 10:06:30 PM »
Since M3 is a spindle command Mach 3 has a dwell setting for the spindle to come up to speed. You need to adjust the dwell.
Re: Help! Mach 3 glue dispenser !!
« Reply #2 on: July 22, 2017, 11:43:11 PM »
Hi,
I recall a conversation a while back where a guy had problems with excessive paint buildup and the beginning an end of a Gcode
programmed spray painting machine.

My solution was to start the move and after a suitable delay turn on the paint/glue/whathaveyou.

At this point Tweakie suggested looking at M10 and M11. My understanding is that when an M11 (start command) is issued it is delayed until
the beginning of the next move, ie the glue dispenser would not operate until the X-Y axes started moving. I understand it came as a result
of those wishing to use laser marking, it prevents excessive marking at the beginning of the move.

It is not a focus of mine and therefore have no knowledge of it outside this brief conversation but I think there may be a programmatic
solution to your problem.

Craig
My wife left with my best friend...
     and I miss him!

Online Tweakie.CNC

*
  • *
  •  7,808 7,808
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Help! Mach 3 glue dispenser !!
« Reply #3 on: July 23, 2017, 02:13:28 AM »
If reducing the Spin Up /Spin Down delays to zero (Config. / Ports and Pins / Spindle Setup) does not produce sufficient reduction in the M3/M3 delays then this may be the next step...
Try using the M11/M10 command set - this will certainly reduce the delay you have experienced with the M3/M4 commands and should prevent the 'pooling' that you mention.
This short description of the M11/M10 commands is intended for laser switching but you should find that it is relevant to your application: http://hobbycncart.com/publ/cikkek/mach3_temaju_cikkek/switching_a_laser_under_mach_control/8-1-0-29

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Help! Mach 3 glue dispenser !!
« Reply #4 on: July 23, 2017, 06:16:36 AM »
Great! I'll follow that up.. Thanks for your reply!