Hello Guest it is November 12, 2019, 08:44:08 PM

Author Topic: Limit switch set up on Mach3 with the Gecko g540  (Read 4144 times)

0 Members and 1 Guest are viewing this topic.

Offline TPS

*
  •  1,406 1,406
    • View Profile
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #20 on: March 08, 2018, 10:03:25 AM »
had a quick look to your XML, you posted.

there is the e-stop is emulated enabled.

is your e-stop realy emulated ?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #21 on: March 08, 2018, 10:06:23 AM »
Yes, I will make that call today. I though I saw a hint of non-continuity on pin 15 of the Dsub25 gender changer.

Offline TPS

*
  •  1,406 1,406
    • View Profile
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #22 on: March 08, 2018, 10:07:43 AM »
do you have a "real" e-stop button ?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #23 on: March 08, 2018, 10:11:43 AM »
The emulated box is unchecked. I'm using an SPST switch for ann estop. It reads 0.2 ohms.

Offline TPS

*
  •  1,406 1,406
    • View Profile
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #24 on: March 08, 2018, 10:17:04 AM »
can you see input15 changing if you push the button in the uc100 i/out Monitor?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #25 on: March 08, 2018, 10:22:16 AM »
Are you referring to the actual switch I'm using for an estop? Or a "button" in the UC100 in/out monitor?
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #26 on: March 08, 2018, 10:32:11 AM »
Watching the UC100 in/out monitor closing or opening the mechanical switch does nothing. No change in the monitor... Red box stays red regardless of switch being open or closed.

The only time that Estop light goes out is for the split second after I press reset... Then it goes blank for a half second or so, then back to red.
« Last Edit: March 08, 2018, 10:36:21 AM by dorrisant »
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #27 on: March 08, 2018, 10:39:44 AM »
Here are some pics...

Offline TPS

*
  •  1,406 1,406
    • View Profile
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #28 on: March 08, 2018, 10:39:46 AM »
can you please post your XML again?

you said Emulated is unchecked, the XML you posted earlier says emulated is checked.

if your e-stop Switch is connected to pin15 the led in UC Monitor shouls Change if you Switch it.
 
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Limit switch set up on Mach3 with the Gecko g540
« Reply #29 on: March 08, 2018, 10:56:15 AM »
Sure... and thank you for your help!