Hello Guest it is January 21, 2021, 12:11:20 AM

Author Topic: STEPGEN = 0  (Read 4334 times)

0 Members and 1 Guest are viewing this topic.

« on: April 16, 2017, 05:37:23 PM »
im currently in the process of converting my CNC over from a USB smooth stepper to the Integra, as well as from mach 3 to 4.

i have everything wired up properly  ;) but none of the motors will budge. when i attempt to jog them in mach 4 the DRO's just sit at 0.

under Diagnostics-> Hicon i can see the Cammand Pos and Following Error move with the jog buttons, but StepGen and the DRO's sit at 0.

sounds like a missed a checkbox somewhere.

i tried to download the integra mach4 profile off the website, but the folder doesnt contain any *.m4prof files =[

any ideas?
« Reply #1 on: April 16, 2017, 06:45:43 PM »
to make sure im not crazy, i went back to mach 3 and the old USB smooth stepper and everything jogs back and forth and the DRO's move accordingly.  :)
« Reply #2 on: April 17, 2017, 03:10:49 PM »
We have updated the website and now the sample profile is in .m4prof format. It is available in the download area:


After you download the file run Mach4 (C:\Mach4-Hobby\Mach4GUI.exe) and click Import Profile and browse to the downloaded file (Mill3Axis-Integra.m4prof).


Ricardo T.
« Reply #3 on: April 17, 2017, 06:31:28 PM »

thanks for the super fast response!

profile the .m4prof imported fine, i can tell the inputs/outputs have changed. Control input and output came as MACHxx and Stepper.  but i still have the same problem. Cammand Pos and Following Error move with the jog buttons, but StepGen the DRO's and the motors sit at 0 =[

« Reply #4 on: April 18, 2017, 02:32:19 PM »
Try rebooting your PC and cycle power to the controller. If that doesn't solve the issue we can remote login using Team Viewer and do some troubleshooting.
« Reply #5 on: April 22, 2017, 02:12:18 PM »
unfortunately rebooting everything didnt help.

but i have a suspicion it might be e-stop related. the command prompt that runs in the background of mach 3 keeps posting "mach external still set". which isnt super descriptive but it does seem significant. see attached image.
« Reply #6 on: April 22, 2017, 06:33:58 PM »
what times are you guys available to remote login? (eastern std time)  im guessing you work the same hours i do?
« Reply #7 on: April 22, 2017, 08:33:36 PM »
Are you using Mach3 or Mach4?

Do you see Integra in the vsiDeviceManager network scan?

you can call the office at 9:30am AZ time weekdays and we can do a remote login.

If you are using Mach4, email a screen capture of diagnostic > vital > hicon status window to the support email address.

« Reply #8 on: April 23, 2017, 08:59:11 AM »
ok so, problem solved  ;D. operator error is to blame for this one, well that and not having a proper understanding of what the software was looking for...

i had bought the 7737 expansion with the integra and never plugged it in because i hadn't bought the license for closed loop yet... however, it was enabled inside of the VSI device manager. once i found that setting i left it enabled, plugged in the 7737, and still nothing... imported a fresh copy of the Integra mach 4 profile and BAM!!!! off and running! the funny thing is the motors are still wired into the integra, the 7737 is just dangling by the ribbon cable with 24+ and the e-stop jumped out.

but who cares!!!! she runs!!!

now i just need to find that spool of ethernet wire and try running through the 7737, but i have a feeling it'll work just fine.

ok so, Vital Systems, thank you for your wonderful product, your assistance in this matter, and my apologies for the stupid on my part!
« Reply #9 on: April 23, 2017, 09:11:38 AM »
Hi Overcooked,
Nice to see someone admit that they didn't know everything.

They guys from Vital are great to work with which is why I have been a happy user all these years.
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.