Author Topic: Disable Dereferences my axis  (Read 1304 times)

0 Members and 1 Guest are viewing this topic.

Online Cbyrdtopper

  • Active Member
  • Posts: 634
    • View Profile
    • Byrd Tool Corp.
Disable Dereferences my axis
« on: March 03, 2017, 09:57:53 AM »
When I use the reference all home button, It will home X,Y,Z, and A great but then it disables Mach4 and then my axis are dereferenced.  How can I make make the Disable not dereference the axis? 
Chad Byrd

Offline Vital System Support

  • Active Member
  • Posts: 329
    • View Profile
Re: Disable Dereferences my axis
« Reply #1 on: March 03, 2017, 11:14:43 AM »
Hello,

There is a setting for each motor in the plugin config (somewhere to the upper right of the window) with a checkbox to dereference an axis on disarm, or not.


-Marc Lim
Vital System Inc.

Online Cbyrdtopper

  • Active Member
  • Posts: 634
    • View Profile
    • Byrd Tool Corp.
Re: Disable Dereferences my axis
« Reply #2 on: March 03, 2017, 05:22:11 PM »
Hey Marc,
Thanks for the reply!  My screen is oriented in Portrait, and for some reason it cuts off  some of the Hicon Plugin Config window, however, I could read "Dere..." on the right side of my screen, so I unchecked that box assuming that was it and it worked.  Now Mach is behaving almost how I want it to.  It still dereferences the Axis when I use the Ref All button, but when I just home them individually it keeps them referenced when I Toggle Mach enable state.  This I can live with no problem!!
Thanks for the help! 
Chad Byrd