Hello Guest it is October 17, 2019, 04:56:57 AM

Author Topic: Spindle not working  (Read 8729 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle not working
« Reply #10 on: February 22, 2017, 04:28:11 AM »
Excellent purchase, you will not be disappointed.  ;)

The settings you need to copy are under the Config. tab (native units, ports & pins, motor tuning, etc.).
I think the easiest way is to copy and save your existing Mach3 folder (perhaps rename it to Mach3old), make the new install, then copy over your settings one page at a time (Mach3 saves your settings to <your profile>.xml when it is closed). This will ensure you have a clean and uncorrupted .xml file.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Bucks

*
  •  23 23
    • View Profile
Re: Spindle not working
« Reply #11 on: February 22, 2017, 04:43:10 AM »
THANKS for the info Tweakie it's much appreciated, the profile we got from the Chinese wasn't a fully loaded working profile (if you get what I mean) we had to go through all the parameters one by one using there instruction manuals & had to find some info on google & YouTube, were just in the process of starting from fresh & then will follow the install & config guide as you suggested & see how far we get!

Offline Bucks

*
  •  23 23
    • View Profile
Re: Spindle not working
« Reply #12 on: February 22, 2017, 11:40:11 AM »
As far as i know we've setup all the parameters but the spindle still isn't working! as far as i know the stepper motors are all working fine & soft limits set etc its just the spindle motor which wasent very clear on the instructions weve got! is there any other software/plugins/drivers etc we'll need from the Chinese for this machine to work apart from the plugin for the rnr usb controller? ive attached the new (legal) profile  :)
« Last Edit: February 22, 2017, 11:42:55 AM by Bucks »

Offline Bucks

*
  •  23 23
    • View Profile
Re: Spindle not working
« Reply #13 on: February 22, 2017, 04:52:12 PM »
Anyone willing to help?

Offline Bucks

*
  •  23 23
    • View Profile
Re: Spindle not working
« Reply #14 on: February 23, 2017, 04:21:16 AM »
I've just had a email notification saying that you've replied to this thread Tweakie, but I can't see a reply!

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle not working
« Reply #15 on: February 23, 2017, 04:28:37 AM »
I made a few changes to your .xml – Unfortunately, I was assuming you were using the parallel port which I have now realised is not the case (the file is attached).

We need to have the details of both your external motion controller setup and your VFD setup to get the spindle control working correctly.
If you attach (or e-mail me a copy) of your pluging installation I will see what I can do.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Bucks

*
  •  23 23
    • View Profile
Re: Spindle not working
« Reply #16 on: February 23, 2017, 04:35:18 AM »
THANKS for your help it's much apreciated!
Sorry to be so dumb but I'm not 100% sure what you mean by external motion controller setup & vfd setup! Where will I get this information?

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle not working
« Reply #17 on: February 23, 2017, 05:34:41 AM »
Your CNC controller has (internally) a USB motion controller which may have setup details, your VFD will also have setup details and we need the information on these to be able to make an educated guess on the Mach3 settings.

There is a post on CNCzone which is of interest - check out post #25 here : http://www.cnczone.com/forums/chinese-machines/320698-cnc.html

Does this setup work ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle not working
« Reply #18 on: February 24, 2017, 07:21:57 AM »
Well, the Chinese setup (from their CD) for the spindle operation makes no sense to me and it is different to the settings used by the CNCzone guy.

For what it is worth here are the Chinese screenshots ;

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Bucks

*
  •  23 23
    • View Profile
Re: Spindle not working
« Reply #19 on: February 25, 2017, 06:13:57 AM »
Probably still some tweaking to do but I'm getting there! THANKS to help from Tweakie & (MacTec54 @ CNCZone) your help is much appreciated  :)
« Last Edit: February 25, 2017, 06:17:49 AM by Bucks »