Hello Guest it is March 28, 2020, 10:42:45 PM

Author Topic: Threading problems  (Read 10988 times)

0 Members and 1 Guest are viewing this topic.

Threading problems
« on: January 29, 2017, 08:18:35 PM »
Having some problems threading with a DSPMC and Mach3. Can not seem to get a clean cut and consistent pitch to the point where the thread is a complete mess. The thread looks to start ok in the first few passes but as the program continues the pitch gets lost to the point where the tool looks to be lagging behind. Trying to recut the thread on the same piece of stock starts the thread in a different position radially then the original cut was performed.

Setup is as follows:

- Spindle encoder 1000ppr set to 4000 on config screen
- Cutting rpm is 210
- Thread to cut is 40 x 1.5mm x about 12mm long
- The lathe setup units are in metric but the program file is imperial (G20)

Both G32 and G76 thread cutting has the same issues.

Thread portion of Gcode file below:

N188 T0505
N189 G97 S210 M40
N190 M03
N191 G94 G54 G0 X.8374 Z1.5457 M8
N192 X.7842
N193 G95 G32 Z.8323 F.05906
N194 G0 X.8374
N195 Z1.5439
N196 X.781
N197 G32 Z.8323 F.05906
N198 G0 X.8374
N199 Z1.5422
N200 X.7778
N201 G32 Z.8323 F.05906
N202 G0 X.8374
N203 Z1.5404
N204 X.7746
N205 G32 Z.8323 F.05906
N206 G0 X.8374
N207 Z1.5386
N208 X.7714
N209 G32 Z.8323 F.05906
N210 G0 X.8374
N211 Z1.5369
N212 X.7682
N213 G32 Z.8323 F.05906
N214 G0 X.8374
N215 Z1.5351
N216 X.765
N217 G32 Z.8323 F.05906
N218 G0 X.8374
N219 Z1.5333
N220 X.7618
N221 G32 Z.8323 F.05906
N222 G0 X.8374
N223 Z1.5315
N224 X.7586
N225 G32 Z.8323 F.05906
N226 G0 X.8374
N227 Z1.5298
N228 X.7554
N229 G32 Z.8323 F.05906
N230 G0 X.8374
N231 Z1.5298
N232 X.7554
N233 G32 Z.8323 F.05906
N234 G0 X.8374
N235 Z1.5298
N236 X.7554
N237 G32 Z.8323 F.05906
N238 G0 X.8374
N239 Z1.5298
N240 X.7554
N241 G32 Z.8323 F.05906
N242 G0 X.8374
N243 Z1.5298
N244 X.7554
N245 G32 Z.8323 F.05906
N246 G0 X.8374
N247 Z1.5457
N248 M9
N249 G30 U-.1 W0. M05
N250 M30

Tried the following versions of Mach3, DSPMC plupin, SyncRay file, and FPGA files and all gave the similar results.

- Tried plugin with SyncRaySG-8.11 and fpga DSPMC-E104 also tried plugin with SyncRaySG-9.05 and DSPMC_E901_FPGA, same results
- Tried different versions of Mach3 (v66, v62, and v57) all same results

Tried the special threading logic inside plugin as well with no change in results.

Anyone have an idea how to get threading to work?
Re: Threading problems
« Reply #1 on: January 31, 2017, 01:27:32 PM »
Threading problems solved!!!

Here is what found.

- Use Spindle feedback in sync mode must be checked
- Spindle Speed Averaging must be checked
- Must be in exact stop mode (G61) vs constant velocity mode (G64)
- Debounce interval = 0
- Index debounce = 100
- Special threading logic inside plugin is required to get proper thread pitch (#1000 = 7762 and #1001 = 1 before G32). Without it the pitch will be finer than expected.
- In the DSPMC plugin, threading feedback sampling time = 50
- Currently using Mach3 v66

Using the above settings gave consistent pitch and good thread form

I have not tried G76 yet but I suspect the results will be the same as G32.

My original mistake was thinking the DSPMC took over threading in a similar way it does for rigid tapping based on the special code that needed to be on. What I realized is that Mach3 still has control of the thread and the DSPMC is essentially following orders.

I hope anyone else using a DSPMC with Mach3 on a lathe finds this useful.