Hello Guest it is November 18, 2019, 12:17:00 PM

Author Topic: Is G31.1 for a second probe implemented in the ESS plugin form Mach4?  (Read 1740 times)

0 Members and 1 Guest are viewing this topic.

G31.1 does not currently work in my hands even though the BOB and ESS have pins connected correctly and the probe lights up on the board and in diagnostics.
It looks like only a single probe controlled by G31 really works in Mach4 with ESS at this time.  Yes, it works great and I appreciate that.  But what happened to the concept of a second probe being implemented?

I have a second probe which is recognized by ESS and the BOB.  Mach4 even sees it light up with contact on the Diagnostics screen but simply is not recognized (even though the board indicator lights up on contact) during a G31.1 move.

Why is it documented on page 20 in the Mach4 Mill Programming Guide if it does NOT work?  Even the #variables are not as advertised in the manual apparently.
The manual says #5071 and #5071 are for G31.1 (a second probe) x and y position values.  However, on another list by Scott Shafer dated 5/28/2015 those variables
are actually G31 machine positions..

Guess I will use a switch to go between the 2 probes.  Many hours wasted to figure that out...  Lots of discussions about probing frustrations that I could find on the forum but no definitive conclusions otherwise about success with a second probe let alone a 3rd or 4th probe.  Is this an ESS plugin or a Mach4 issue?

Thanks

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Is G31.1 for a second probe implemented in the ESS plugin form Mach4?
« Reply #1 on: April 23, 2017, 01:36:41 PM »
The Warp9 forum would probably be a better place to ask.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Is G31.1 for a second probe implemented in the ESS plugin form Mach4?
« Reply #2 on: April 23, 2017, 02:33:07 PM »
The Warp9 forum would probably be a better place to ask.
Done thanks.  I did wire in parallel and it works fine with 2 probes on the same circuit.