Hello Guest it is October 23, 2019, 12:19:17 PM

Author Topic: Error using Smooth Stepper and Mach 3  (Read 7100 times)

0 Members and 1 Guest are viewing this topic.

Error using Smooth Stepper and Mach 3
« on: January 28, 2017, 12:32:21 PM »
Long story is I ran my sherline mill on an old comp that had printer cable. Ok now that one died and so loaded mach 3 on main comp, loaded software for Smooth Stepper ect ect.

Now the sherline mill with Mach 3 runs great after couple of hours of resetting things and doing motors to run smooth, until, I start the spindle then I get the following error and everything stops.


[imghttp://][/img]

Anyone tell me what I can do short of throwing things out the window...

thanks for your time
Jim

Offline Tweakie.CNC

*
  • *
  •  7,958 7,958
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Error using Smooth Stepper and Mach 3
« Reply #1 on: January 29, 2017, 03:35:50 AM »
Hi James,

Can you post your <Proflle> .xml file from your Mach3 folder. Copy and rename it to james.xml before posting - I will take a look and should be able to advise where the problem lies.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Error using Smooth Stepper and Mach 3
« Reply #2 on: January 29, 2017, 09:30:32 AM »
ok, there are 3 xml files but took the one for mill since that is all I use.

I attached what I think is the file.

Thank you for your time.

JimN
Abbotsford, BC

As a note, I only use the motor that came with the mill. So nothing fancy just basic milling to make motor mounts ect for RC Airplanes. And use 3 stepper motors with Xylotex board that is maybe 8 years old.
« Last Edit: January 29, 2017, 09:36:01 AM by JamesBC »

Offline Tweakie.CNC

*
  • *
  •  7,958 7,958
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Error using Smooth Stepper and Mach 3
« Reply #3 on: January 29, 2017, 11:01:15 AM »
Hi Jim,

Your .xml set-up runs OK here so the problem is probably more to do with the USB side of things.

This is an extract from the USS documentation relating to your FT_IO_Error…

1.   Make sure your USB cable is firmly connected.  The cable could be loose, and movement could be causing your issue.
2.   Make sure that you are not using one of those little wind up USB cables.  They cause lots of noise and data errors.
3.   Try a different normal USB cable.  The one you are using might be damaged
4.   Make sure you are connected directly to your PC and not through a USB HUB or a monitor's USB Hub.  Some HUBs are flaky and can cause packet drops.
5.   Try a different USB port on your PC.  I have seen this fix problems several times.  It could be because there are fewer USB devices on the new port, or it has less noise on it inside the PC.
6.   Disconnect as many other USB devices as possible from your computer.  One of them could be malfunctioning.
7.   How long is your USB cable to the USS? The shorter the cable length, the less noise it can pick up.  This will help if you are getting weird or intermittent dropouts.
8.   Make sure the USB cable does not run alongside from any high voltage or high current wires or other noisy wires. If the USB cable has to cross other wires, make sure it crosses at a 90 degree angle.

Other points to consider:
1.   How are you powering your USS (USB SmoothStepper)?  Poor or noisy voltage can cause the USB connection to drop out
2.   How are you powering your Break Out Board?  Poor or noisy voltage can cause the USB connection to drop out. 
3.    How much current is your BOB consuming?   If the BOB is pulling power from your USS, it could be taking too much power and causing the USB issues you are seeing.
4.   Can you try to turn off your dust collection system and see if you can do an air cut?  Can you ground your table and axes to ground and do an air cut? 
5.   Another good step is to turn off the Windows Power Saving options for your internal (on motherboard USB hubs).  Go into Device Manager and then for all of your USB Root Hubs and Generic USB hubs. Uncheck the "Allow computer to turn off this device to save power" option.  Why do we say all?  Because it is slightly harder to determine which hub your USS is plugged into, and if you ever change connection locations, it may become associated with another Hub.
(Open the device manager by pressing the “WINDOWS” key and the “R” key at the same time.
When the "Run" box opens up, type in "devmgmt.msc".
For each USB Root Hub and Generic USB hub, uncheck the "Allow computer to turn off this device to save power" option).


It may also be worth checking with a multimeter that the screen of the USB cable does not make a continuous circuit between the two metal outer casings of the two plugs. If it does then obtain a USB cable which does not have this continuity of the screen.


Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Error using Smooth Stepper and Mach 3
« Reply #4 on: January 29, 2017, 01:54:36 PM »
Ok first thanks for the help.

1] USB cable goes in tight and even moving the cable does not cause any problem with Mach 3 as long as spindle is not turned on.
2] 24 inch high speed usb cable, was the best around according to the computer store.
3] Tried a 6 foot one from the dollar store, same mach 3 works fine tell I turn on spindle.
4] Direct to mother board USB on back.
5] Tried, same as before.
6] Only other USB is the keyboard and its hooked to a power hub, I use the power hub to charge things but not while ruining mach 3.
7] 24 inch
8] Runs along back of comp, doesn't even run by power supply in computer.

Other things
1} Power from Comp
2] ? have no idea, was hooked up like Smooth Stepper info said to do it.
3] If this was happening would it not cause Mach 3 to loose steps?
4] Dust collection, LOL you mean my small cordless vac that I use when cutting G-10...
5] Done, no change.

Well again thanks for your time and help, I can run files and cut with the mill, just have to remember that Mach 3 will not shut down the spindle on an M3 command, nor on an emergency stop.
I just run an extension cord to plug the spindle into.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Error using Smooth Stepper and Mach 3
« Reply #5 on: January 29, 2017, 01:59:21 PM »
Try finding a shielded usb cable, and adding some ferrite beads to it.
Your VFD is causing interference on the USB cable.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Error using Smooth Stepper and Mach 3
« Reply #6 on: January 29, 2017, 03:01:35 PM »
Thanks, it is a shielded USB.
Not sure what a VFD is, but I still can't understand why Mach 3 runs just fine through cuts and tool changes. As long as I run the spindle from an extension cord.
I even opened up the box that the stepper motors plug into, and the spindle plug and changed the relay for a new better one. No change.

thanks for all the help

Not like I am a production shop, little bit of cutting I do can just run the spindle on extension cord for now.

Re: Error using Smooth Stepper and Mach 3
« Reply #7 on: February 02, 2017, 10:48:28 AM »
Ok, have this figured out now. Problem was in Cam software which after an update was putting in spindle speed and direction of rotation.

Of course my system is not that advanced so Mach 3 stopped with error since it could not get a check on the above two items.

After telling the cam software to not worry about spindle everything works like always.

Just wanted to post this in case someone else might have the minor problem.

thanks
Re: Error using Smooth Stepper and Mach 3
« Reply #8 on: February 02, 2017, 11:54:35 AM »
ok, Spoke to soon, that is not the problem.

Re: Error using Smooth Stepper and Mach 3
« Reply #9 on: February 06, 2017, 10:36:46 AM »
This problem was resolved over here http://warp9td.com/index.php/kunena/7-general-discussion/6438-error-on-spindle-start?limitstart=0

Reloading the USB driver fixed the problem.

Andy