Hello Guest it is November 21, 2019, 09:00:26 PM

Author Topic: Mach 3 and UC100 usb motion control install problem....  (Read 5135 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 and UC100 usb motion control install problem....
« on: May 23, 2015, 02:29:57 PM »
So I finally got to the point of getting my home cnc machine ready for running.

Problems right off the get go with the driver install.

I'm installing on a windows 7 64bit system.
version of Mach 3 is Version R3.043.066

and installing a UC100 USB motion controller (V2.148) since there is no parallel port.

When I start mach these errors pop up:

Plugin DLL Defective. Reload

UC100 V2_148.dll - Defective Plugin Found..ignoring

Plugin DLL Defective. Reload


So now what ?!
Do I have to update Mach3?
Do I have to update the uc100?

 ???

any help much appreciated,
thx

Re: Mach 3 and UC100 usb motion control install problem....
« Reply #1 on: May 23, 2015, 02:51:31 PM »
Is your controller card working after you open the mach3 and click ok for errors?

I was same problem with my usb card but I didnt work on it after I understand my card is not supporting thc signals. But after I click ok for errors the card was working...

I think its an installation problem or bug, just a thought.
Re: Mach 3 and UC100 usb motion control install problem....
« Reply #2 on: May 23, 2015, 03:01:45 PM »
rookie errors...

didn't realize i had to have the card actually connected for the install to work correctly....no errors now
Re: Mach 3 and UC100 usb motion control install problem....
« Reply #3 on: June 15, 2015, 03:39:52 PM »
how to configure autozero with touch plate in mach3? can you help me?
Re: Mach 3 and UC100 usb motion control install problem....
« Reply #4 on: February 17, 2017, 09:06:14 PM »
I also have a install problem with this install.  Following the directions from UC100 I was in a bit of a hurry.  I didn't see all the options on the window that dropped saying check . well UC 100 wa checked so I said install and opened Mach 3 as instructed,  the box pops up wit uc300 and uc400 , I cant get rid of them, , any suggestions.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Mach 3 and UC100 usb motion control install problem....
« Reply #5 on: February 18, 2017, 06:59:09 AM »
Check the Mach3\plugins folder and delete the UC300 and UC400 plugins. Not sure how you would have installed those, though, with the UC100 installer??

Best to just delete all the plugins and start over.
Go here, and download the plugin for manual installation. (option 3) http://www.cncdrive.com/UC100.html

Copy it to Mach3\plugins, and then double click on it. It'll say "plugin installed"

Then download the USB drivers, and install them.
It should then work fine.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach 3 and UC100 usb motion control install problem....
« Reply #6 on: February 19, 2017, 02:17:48 AM »
thanks Gerry  I did all this and it ran once then I was programing the steppers and I get the  message that the driver cant be found, check cables   so did that and I see the green light and the blue one.  The directions say to download the  USB drivers again.  Can you leed me to where the proper drivers are.

its great some people take time to help unknowledgeable people or  in my case dummy's like me lol