Hello Guest it is December 06, 2019, 01:34:06 AM

Author Topic: Help with my profile  (Read 834 times)

0 Members and 1 Guest are viewing this topic.

Help with my profile
« on: January 22, 2017, 10:50:18 AM »
Been going thru this for days and can't figure out what I'm doing wrong.  hoping someone out there will be kind enough to look this over and let me know what's wrong... Ive attached my M4 profile for you to look at...

Here's the issues I'm having:

1) Z limit - any time I enable anything to do with the Z limits, I get a "Limit Switch Z++ Tripped!" Error and my LED's on the Diagnostics tab light up. At point I can't do anything with the macnine.
2) Homing - X axis homes as it should and backs off the switch, but Y axis goes to the limit switch and stays there with a "Home switch Y tripped message. Z axis I don't know yet because I can't get the switches to work.

Now I could probably set it all up with the soft limits and soft homing, but the software is supposed to perform these tasks and I'd love for it to work properly!

For reference, here's my machine set up:

C10 Break out board
ESS from Warp 9 version 186
Mach 4 v. 4.2.0.3233
Automated technologies motors. X and z are 570 oz and Y is 906 oz.
My limit switches are chinese made generic and are of the NO/NC variety.   I have them wired NC and in series.

Not sure what other info I could provide other than my sincere appreciation to you guys for helping me with this!

Thanks again - Bob


Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
Re: Help with my profile
« Reply #1 on: January 22, 2017, 11:26:22 AM »
One of the firsts things you need to do is a little upgrade, but first backup your old so you have a reference to your current settings

Install latest version of mach4 if not already done,
after loading mach4 use a copy of the wx4 screenset (you have the very very old wxmach loaded)
update the ESS plugin to the latesr v193 (you have v186) http://warp9td.com/index.php/kunena/7-general-discussion/5843-ess-mach4-build-193


DazTheGas
Theres always time for a choccy biccy
Re: Help with my profile
« Reply #2 on: January 22, 2017, 10:50:54 PM »
so it turns out the idiot who soldered the limit switch connections inside the case (me) did a crappy job and one of the connections on the Z limit switch was broken.  soldered it back on there and voila!  works perfectly....  Thanks for the advice DazTheGas. I did make those upgrades and things seem to be smoother and I like the wx4 screenset better too..