Hello Guest it is September 19, 2020, 08:57:43 AM

Author Topic: Help For New User  (Read 1562 times)

0 Members and 1 Guest are viewing this topic.

Help For New User
« on: December 16, 2016, 09:38:43 AM »
Hi, can anyone help with how to make my work piece be centred on the table, I'm using Mach3 and all this is new to me, the work is showing in the right hand lower corner of the tool table, I tried to regen toolpath but its still the same, I want to  be able to do all of my work from the centre of my router table, but when loading gcode to Mach3 the cutter is heading over to the right hand lower corner instead of the centre, ive already spent one day trying to figure this out and not getting anyware

Re: Help For New User
« Reply #1 on: December 16, 2016, 09:48:09 AM »
Just want to add that I jogged to the centre of my work piece and then did ref all home but its still the same

Offline Davek0974

*
  •  2,597 2,597
    • View Profile
    • DD Metal Products Ltd
Re: Help For New User
« Reply #2 on: December 16, 2016, 12:55:15 PM »
Is the code generated with the centre as home?

sounds like it has home as the lower right maybe.

If you park the tool over the work and do a path regen it should show the tool paths, if they all stay inside the work then good, if there is a path shown that is way off to one corner then something in the code is telling it thats where home is possibly.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.
Re: Help For New User
« Reply #3 on: December 16, 2016, 02:05:59 PM »
Thanks for your quick reply, I have no idea if the code was generated with the centre at home, I'm using Artcam and cambam to automatically generate the gcode, if I park the tool over the centre of the work and do a regen the crosshairs in the mach3 screen are almost dead centre over the top of the picture, ive been playing around with it and it seems a lot better now, the only problem is that the machine is cutting smaller than it should do, for example to test I made a gcode letter "A" that I programed to engrave at a height of 10mm but when it actually cuts into the work the size of the engraved letter is about 1mm in size, I did play around with the motor tuning a bit and not sure if its right, before my computer crashed and had to reinstall Mach3 it was all working fine.

Offline Davek0974

*
  •  2,597 2,597
    • View Profile
    • DD Metal Products Ltd
Re: Help For New User
« Reply #4 on: December 16, 2016, 03:34:09 PM »
sounds like maybe the units are set for inches and the code is expecting metric or the steps per unit are totally wrong.

check the units setup first then verify the calibration / steps per unit setup.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.
Re: Help For New User
« Reply #5 on: December 16, 2016, 05:32:38 PM »
Ha you were right, it was set to inches and all my code is mm, thanks very much for your help

Offline Davek0974

*
  •  2,597 2,597
    • View Profile
    • DD Metal Products Ltd
Re: Help For New User
« Reply #6 on: December 17, 2016, 03:43:13 AM »
No worries, its always the simple things that get us ;)
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.