Hello Guest it is April 23, 2019, 06:53:16 AM

Author Topic: Question for Plasma guys on material sensing  (Read 6533 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,784 25,784
  • Carnoustie, Scotland
    • View Profile
Re: Question for Plasma guys on material sensing
« Reply #30 on: December 06, 2016, 03:20:24 PM »
Just an update on this, Wojtek got back to me regarding the M124 macro, it seems Mach has issues with coordinates synchronization during G31. in versions after  044 and hence the epid error. Why it only affects it when run from G Code I have no idea but I installed 044 today and removed the write to Z dro line I had put in to get it working and it was fine.
 It  may have also cleared up an issue I had that if the computer was sitting idle for a long time it would kind of half lock up, for example I could jog etc but MDI would not do anything. Strange thing is I have 062  (which is what I was using) on all my other machines, one of which uses the IP/A, and I have no such issues. Will have to wait a while though to be sure it has cleared up that issue.

 Regarding the original M31 problem which lead to me to find this one, they are still looking into it and will let me know if they find the problem.



Offline Chaoticone

*
  • *
  •  5,472 5,472
  • Precision Chaos
    • View Profile
Re: Question for Plasma guys on material sensing
« Reply #31 on: December 06, 2016, 03:24:09 PM »
Thanks for the update Hood.

Did you get your fan yet?
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Hood

*
  •  25,784 25,784
  • Carnoustie, Scotland
    • View Profile
Re: Question for Plasma guys on material sensing
« Reply #32 on: December 06, 2016, 03:26:05 PM »
Not yet, still waiting for the call to say it is in.

Offline Davek0974

*
  •  2,422 2,422
    • View Profile
    • DD Metal Products Ltd
Re: Question for Plasma guys on material sensing
« Reply #33 on: December 06, 2016, 03:34:01 PM »
Interesting, that may explain whether told me to always install version 022, I did query this on the forum and it was decided that it was too old for consideration, maybe 044 is a better bet?
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline Hood

*
  •  25,784 25,784
  • Carnoustie, Scotland
    • View Profile
Re: Question for Plasma guys on material sensing
« Reply #34 on: December 06, 2016, 04:18:10 PM »
Interesting, that may explain whether told me to always install version 022, I did query this on the forum and it was decided that it was too old for consideration, maybe 044 is a better bet?

That is indeed interesting Dave. Ver 022 was the version I used on the wee lathe that improved the pullout at the end of the threading when using the IP/S, any version after that and the pullout was a lot slower. Problem with that version was Spindle Override did not work for me, also there were a few additions to things in Lathe after that version such as tool number DRO and description  to display correctly, and that is why I needed to use newer versions for the lathe.

Offline Hood

*
  •  25,784 25,784
  • Carnoustie, Scotland
    • View Profile
Re: Question for Plasma guys on material sensing
« Reply #35 on: December 10, 2016, 03:29:54 PM »
Ok freezing problem after sitting a long time idle was not solved by the older version as it happened again yesterday. It is a strange on as the machine will still jog via MPG but it won't respond to a button that has G Code in it X0Y0 button) but forgot to try out with some actual code. Hopefully I will remember next time it happens.

Offline Hood

*
  •  25,784 25,784
  • Carnoustie, Scotland
    • View Profile
Re: Question for Plasma guys on material sensing
« Reply #36 on: December 11, 2016, 01:56:48 PM »
Couldn't be bothered climbing up onto the plasma to see what the label said but  did the calcs and looks like it is 10.25:1 reduction box.
Now spot on :)