Hello Guest it is July 20, 2019, 04:54:38 PM

Author Topic: New cnc machine running but....  (Read 6022 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

*
  • *
  •  7,849 7,849
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: New cnc machine running but....
« Reply #30 on: December 18, 2016, 03:15:49 AM »
Your wiring should be something like this, with the addition of 5Volts supply to the BoB (not sure about using a BEC as I have never tried that).

Tweakie.
« Last Edit: December 18, 2016, 03:17:45 AM by Tweakie.CNC »
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: New cnc machine running but....
« Reply #31 on: December 18, 2016, 11:18:53 AM »
I think it will work the BEC is rated for over 25v , does the 5v for the b.o.b go into the p14 ?Where does the ground go from the BEC ?
Re: New cnc machine running but....
« Reply #32 on: December 18, 2016, 11:49:12 AM »
THANKS TWEAK ! I finnaly got my motor to turn ,however I can only jog it one way , here is a video of my machine settings https://youtu.be/9v5qi3_ZDaU

Thanks again

Wes

Offline Tweakie.CNC

*
  • *
  •  7,849 7,849
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: New cnc machine running but....
« Reply #33 on: December 19, 2016, 01:48:27 AM »
You are making progress.

Try selecting Step Low Active for your X axis (Motor Outputs) and see if that makes a difference.

Also measure the voltage on your Parallel Port X axis Direction pin (between pin 3 and pin 25) it should change between approx. 0 volts when jogging in one direction and 5 volts when jogging in the other direction. If it only changes between approx. 0 volts and 3.3 volts then that may be the issue.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: New cnc machine running but....
« Reply #34 on: December 20, 2016, 04:17:42 PM »
Hey there I have managed to get my motor to turn the other way but it was just me fiddling around with the jog keys that did it :s please see video

https://youtu.be/zcZY1yiYlrY

Thanks tweak for your help so far !

Wes

Offline Tweakie.CNC

*
  • *
  •  7,849 7,849
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: New cnc machine running but....
« Reply #35 on: December 21, 2016, 02:19:28 AM »
That's more progress.  ;)

I think you need to sort out that keyboard problem before you proceed.

Could be your keyboard, other connected USB devices or your PC.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.