Hello Guest it is August 10, 2020, 09:24:53 PM

Author Topic: Ess Smoothsteper speed problem  (Read 1827 times)

0 Members and 1 Guest are viewing this topic.

Ess Smoothsteper speed problem
« on: October 04, 2016, 03:56:49 PM »
I have tried for ages to get the 0 to  10 volt speed control from the bob to work . No mater how I configure the spindle control I always get 10 volts from the bob. I have used 2 bobs with the smoothstepper to control spindle direction ( 1 relay on each bob) this works fine . This leaves lots of pins to control limits and movements all of which work fine  . I can use a battery or battery's wired  to the vfd to control speed so the vfd works . Any advice on mach setting's or smoothstepper settings to make the bob give 0 to 10 volts and not 10 volts all the time thanks. 
Re: Ess Smoothsteper speed problem
« Reply #1 on: October 05, 2016, 03:23:33 AM »
There's a couple of things you need to configure to get that 0 - 10V DC signal working.  I'm not familiar with the ESS Smoothstepper, so I'll have to discuss in generic terms.

Firstly, you need to know which pin maps to this 0 - 10 volt output.  That should be in the documentation for the Smoothstepper itself.

Then you need to configure the Spindle in Ports and Pins | Spindle tab.  You should have both the "Use Spindle Motor Output" and "PWM Control" boxes checked.  Then set the PWMBase Freq. to an appropriate value (usually 50Hz will work).  You can also set up control relays on this screen to allow start/stop operation of the spindle via that mechanism if needed, but that is out of the scope of this post.

Then you need to go to the Motor Outputs tab and set Spindle to "Enabled" (green check in that column), the Step Pin# to the pin number of your BOB that maps to the 0 - 10V output and the Step Port to the correct port for your Smoothstepper.

This should get your spindle running at varying speeds, but it may operate backwards (full RPM setting in Mach will result in minimum RPM on the spindle and vice-versa).  If that is the case, you'll also need to change the "Step Low Active" to the opposite of what it is (change it from a red X to a green check or from a green check to a red X) and that should get you going with spindle control under Mach3.  I'm not sure how different this may be in Mach4 but it should be similar so if you're using Mach4 then you'll need to consult the user's guide for where these settings are made.

Hope that helps,

Stephen "Highspeed" Kruse
Re: Ess Smoothsteper speed problem
« Reply #2 on: October 08, 2016, 04:50:01 AM »
Smooth Stepper spindle setup is here:
http://www.warp9td.com/index.php/faq/faq-mach3#Spindle

really you are best having a look at the Warp9 website which has come on loads over the past year and is much more helpful (all thanks to Andy at Warp9).

The website supersedes any manuals you may have as they were never completed (one thing always lacking with SS + warp9.... like driver updates [back in your box rob!])

Anyway.... have a look at the FAQ on the warp9 website as there are a number of items within the configuration pages of mach3 that do not relate to the SS as they are configured on the SS-configuration / plugin page as them must be loaded directly to the FPGA upon mach3 resart .... hence the reason why after changing any settings you must restart mach 3 so that the FPGA is reset and the new config settings are uploaded.... yes its a pain but the way it works.... once its setup you don't need to do it but get a backup of your xml file and save it somewhere safe (online storage .... googledrive... dropbox whatever)
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”

Offline rcaffin

*
  •  1,029 1,029
    • View Profile
Re: Ess Smoothsteper speed problem
« Reply #3 on: October 15, 2016, 05:13:18 AM »
Quote
I have tried for ages to get the 0 to  10 volt speed control from the bob to work . No mater how I configure the spindle control I always get 10 volts from the bob. I have used 2 bobs with the smoothstepper to control spindle direction ( 1 relay on each bob) this works fine .
What you have not mentioned is what brand/model BoB you are using. Without that detail no-one can give you a good answer, apart from a WAG.

cheers
Roger
Re: Ess Smoothsteper speed problem
« Reply #4 on: October 15, 2016, 04:27:04 PM »
Thanks a lot . Still no joy top speed ? I have set all the pins ports and pmw just as suggested and still get 10 volts . Its not really a big problem as I have lots of gears and I have speed control with buttons on the vfd, its just annoying . What I have had success with is screwing with the wizard . The threads were all the wrong way except for the first cut. I found a simple solution in some old threads . I changed Test = False to True and a presto it all gets written in G32 and its perfect . It may be that constant speed helps , wot you think  
Re: Ess Smoothsteper speed problem
« Reply #5 on: October 15, 2016, 04:30:36 PM »
Forgot to mention Bob brand . Don't know really they are all over ebay and are the ones supplied by Warp9.