Hello Guest it is October 15, 2019, 06:01:35 PM

Author Topic: Mach3 Turn G95 feed rate changes by itself intermittently  (Read 2123 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Turn G95 feed rate changes by itself intermittently
« on: September 26, 2016, 08:05:38 PM »
I've been using Mach3 Turn for many months on a converted bench lathe and everything has worked as I expected so far. Most of my problems have been easily solved by reading the forum posts.

I recently added a C6 speed control board from cnc4pc so I could use spindle control (I use the C10 breakout board, and C3 index pulse card). I thought I configured it pretty well and get close to the requested spindle speed, both in the Mach3 DRO and against a laser tach.

BUT, I'm experiencing some really odd behavior with regards to G95 and can't figure out what's going on. On an intermittent basis Mach3 will reduce the feedrate, while executing a program, to some unusually low number like 0.0002"/rev. It will often be on like the first couple of roughing passes, but then Mach begins to execute the feedrate specified in the program on later passes. It usually fixes itself as the program goes on. Sometimes it doesn't, and I have to restart the Mach software.

If I stop the program and enter a feedrate in the MDI, it executes fine. It only occurs while executing a program. At no time do I see a drop in RPM in the Mach 'True spindle speed' DRO

What could possibly be causing Mach to ignore a feedrate as specified in a program, but do so on an intermittent basis, and then execute the feedrate later in the same program?

In general I use the following syntax for example:
G97 S800 M3
G95 F0.004
G01 Z X whatever...

Under 'ports & pins' -> 'spindle setup' both 'spindle speed averaging' and 'use spindle feedback in sync mode' are checked.

What am I missing here?

Thanks for any help!

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn G95 feed rate changes by itself intermittently
« Reply #1 on: September 27, 2016, 04:40:06 AM »
Does your spindle take a while to get to speed? If so do you have a delay set in Ports and Pins, Spindle Setup page?

Hood
Re: Mach3 Turn G95 feed rate changes by itself intermittently
« Reply #2 on: September 27, 2016, 08:46:30 AM »
Thanks for the reply Hood.

I used Peter Homann's information (found in many forum posts) to calibrate the spindle. It comes up to speed quickly and is stable.

Under ports & pins, spindle setup, general parameters, all delays are set to '0'.

I've thought this could be an index debounce or debounce interval setting problem?

My index debounce is '0' and the debounce interval is '500'. This setting has yielded accurate and stable 'True RPM' numbers in the DRO. (Any time that I've increased the index debounce to say like 100, my true RPM DRO is much lower than actual RPM).

I've run enough code now to see that it always happens in the beginning of a program and gets corrected during the program.

Thanks for the advice!

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn G95 feed rate changes by itself intermittently
« Reply #3 on: September 27, 2016, 08:48:42 AM »
Set the spin up to 1 second and it should help.
Hood
Re: Mach3 Turn G95 feed rate changes by itself intermittently
« Reply #4 on: September 27, 2016, 09:40:08 AM »
Thanks for the recommendation Hood.

I tried 'Spin up Delay' at 1 sec (also tried 2-5), but noticed no difference in my test program. It always runs the same way.

in the little test program the first few passes will run at F0.0065 but on the last pass it runs at the specified F0.008. I specify S800 and get a True RPM of '776' (both on DRO and measured with laser tach) which is pretty close.

This example isn't terrible as the feed isn't off by too much, but I don't get why it is off at all. Thanks again for trying to help.

Code: [Select]
G20 G90 G18

T0101

( rough )
G95
G97 S800 M3
M08

G0 X0.55
G0 Z-0.2377
G0 X0.5625
G1 F0.001 X0.47
G1 F0.008 Z-1
G0 X0.55
G0 Z-0.2559
G0 X0.5325
G1 F0.001 X0.44
G1 F0.008 Z-1
G0 X0.55
G0 Z-0.2827
G0 X0.5025
G1 F0.001 X0.41
G1 F0.008 Z-0.4011
G0 X0.55
G0 Z0.0
G0 X0.51
G1 F0.008 Z-0.219
G3 X0.5024 Z-0.2239 I-0.005 K0.0
G1 X0.5003 Z-0.2241
G2 X0.4334 Z-0.423 I0.0922 K-0.1178
G3 X0.435 Z-0.4257 I-0.0042 K-0.0027
G1 Z-1

M5
M30
%

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn G95 feed rate changes by itself intermittently
« Reply #5 on: September 27, 2016, 11:04:58 AM »
ok try unchecking the averaging and see if that helps.
Are you using the parallel port?
Hood
Re: Mach3 Turn G95 feed rate changes by itself intermittently
« Reply #6 on: September 27, 2016, 07:28:24 PM »
Yes, I'm using the parallel port with a C10 breakout board.

I unchecked 'spindle speed averaging' and the problem got worse. Any program run using G95 resulted in an actual feedrate of 0.0001"/rev regardless of what was in the program.

So, I enabled spindle speed averaging again, but did try un-checking 'use spindle feedback in sync modes'. That worked for some reason.

All programs ran as expected and the correct feedrate was used. There were no noticeable changes to my spindle speed DRO or ability to call a certain spindle speed.

so, my problem appears fixed.

What have I given up by disabling 'use spindle feedback in sync modes'? I assume threading?

Thanks again for your help. I appreciate you taking the time to help me troubleshoot it.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn G95 feed rate changes by itself intermittently
« Reply #7 on: September 27, 2016, 07:35:31 PM »
Afraid your problem is not fixed :(
By unchecking the feedback in sync you have basically told Mach to ignore the spindle feedback when determining how fast to move the axis.
With it unchecked you will get the feed per rev that is in your code at the RPM that is in your code, but if your spindle is actually faster or slower than the codes RPM then the axis will not be the correct feedrate.
And yes, threading will not work correctly.

Can you attach your xml and I will take a look and see if I can find a problem in it, also if using Ver 066 of Mach I would suggest you go back to Ver 062.

Hood
Re: Mach3 Turn G95 feed rate changes by itself intermittently
« Reply #8 on: September 27, 2016, 07:53:30 PM »
sorry, should have attached that xml on the first post. It should be attached to this one.

thanks for clarifying how the sync works. I guess I was only getting good results because my RPM's are pretty stable.

I am using Ver 066 and have seen a number of posts about folks reverting to 062. I'll do that and see if it helps.

Thanks again.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn G95 feed rate changes by itself intermittently
« Reply #9 on: September 28, 2016, 02:30:59 AM »
I see you have spindle relays disabled, unless things have changed since I last used the parallel port, then I am surprised you are even seeing a RPM showing in Mach.
Might be worthwhile enabling them and setting up for outputs you are not using, probably have to enable the outputs in Ports and Pins as well.

Hood