Hello Guest it is December 06, 2019, 03:08:30 AM

Author Topic: G04 hangs up  (Read 1387 times)

0 Members and 1 Guest are viewing this topic.

G04 hangs up
« on: August 28, 2016, 03:33:54 PM »
Hello all, I am setting up a (new to me) router. I have all the axis motors and I/O working properly. When I first started the spindle M3S5000 it powered up and ran to speed, The dwell LED continues to flash for several minutes.  I entered M5 and the spindle stayed powered up. I hit reset and the spindle stopped. I wrote a small program (below) and it looks like the problem is actually with the G04 timer.

Spindle dwell parameter is 0

N10 G04 P5
N20 M3 S5000
N30 G04 P5
N40 M5

The program hangs at N10 so the spindle never turns on, The dwell LED flashes till I hit reset.

Does anyone have any idea what the problem could be?

Thanks in advance, Dave

Windows XP
USB motion card HXC MK4
Chinese VFD and Stepper drives
Mach3





Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: G04 hangs up
« Reply #1 on: August 28, 2016, 06:25:59 PM »
Just a guess, but your motion controller may not support G04.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: G04 hangs up
« Reply #2 on: August 28, 2016, 07:15:51 PM »
Thanks for the very quick response Gerry!

I uninstalled Mach3 and did a clean install, I then loaded the Machmill profile, With nothing configured I loaded the Gcode test and it worked ok. I configured the motion controller plugin, ran the test and it was ok. I then configured each axis motor and ran the test at each configuration and it was good. With everything configured and ready to run I ran the test and it worked ok no more G4 problems. I powered down the controller and the PC. The G4 problem is back. I tried every Machmill.XML back up and the problem returned in each one. I loaded an unconfigured Mill profile ran the test and it worked ok.
Re: G04 hangs up
« Reply #3 on: August 30, 2016, 07:48:59 AM »
Have you tried g04 p5000?

Some motion controllers work in seconds delay, some in milliseconds , changing the checkbox on the general configuration tab does not change the motion controller settings

Worth a try.

Rob
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: G04 hangs up
« Reply #4 on: August 30, 2016, 06:40:33 PM »
Thanks Rob, I think I just got it fixed, I used auto tune for the step counts, and I accepted a value with a decimal. Apparently using a non whole value messes up the controller.